1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

RF has stopped working

Discussion in 'rFactor 2' started by Rob Every, Jun 9, 2012.

  1. Should be a quick fix guys

    Have had to reinstall W7 onto my machine, and therefore had to put RF2 on again.

    Now I have managed to install the game and it works fine, I have tried a boot up in the game without mods and I get everything OK, menus click through etc and it exits fine.

    I popped my mods and tracks onto an external drive and when i drop them in to packages they all installed fine.

    but when I try and start the game i get a RF stopped working windows icon?

    Is the install on the RF2 site the latest? I have the new Masters modand the latest mods too, how do I check this?

    Has this happened to anyone before?

    AS I say, game works fine with no mods installed, they ahve all been chcked in mod manager both options checked.
     
  2. If you have any mods that are using ISI components [cars or tracks] then uninstall them. ISI updated all of their mods and for example if mod X is using Megane v1.0 then the game will be crashing because there is no v1.0, it's v1.1 now. Install only ISI mods [Historic, Megane, FR3,5, Nissans and FISI] and the game should be running without problems :)
     
  3. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Just a wild guess, but do the following.

    Uninstall ANY non-ISI mod.
    Now check if you have the following versions installed:

    Megane - 1.1
    Formula 3.5 - 1.2
    GT World endurance - 1.1
    Classic 1960's - 1.0
    Formula ISI - 1.0

    If not, update those to that versions first, before installing any other mod. When they are all in the same version as mentioned here, look at the other mods, and install those that are possible.
     
  4. OK, I tell you what I did

    My machine developed a fault which forced me to reinstall 7, from scratch. I did this and saved all the RF2 files onto an external drive, this were updated with the latest updated when teh Master mod came out.

    But, when I transfer across Marco you are right, they are not up to date, how can this be when the ones I saved on the drive were the latest.

    I reckon I shall have to update them all again as if this were a new install. But the versions above in your earlier post are not matching mine, despite them being dragged across and instal,led in the instalelr as most recent update!
     
  5. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Which versions you have now Rob? Then I will point you to the update files ;)
     
  6. Well marco, I now have seen that you can update from within the mod manager?

    If you cright click the file, it has an update option. I think I am up to date, will try game again shortly
    Game is version 85 which is newest right?

    OK man, just tried it it works fine.

    One issue though, how on earth do you do a practice session on your own? I cant seem to select a session with just myself on the track? I use to be able to! I ahve selected private practice, and it just says no other competitors sepected and wont let me start! Weird
     
  7. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Yes, correct.

    Updates indeed happen in the Mod Manager. You can update the current mods there to the latest versions. Make sure you have the same versions as I mentioned above, and all should be working again.