1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Reducing stuttering

Discussion in 'PC | F1 2016 DNA Racing League' started by Mark Saunders, May 22, 2017.

  1. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Hi all,

    When I first started racing in F1 2016 I used to have uses with graphics stuttering, lap stuttering, game crashes as well as computer freezes. It's pretty manageable now but I keep hearing of stuttering issues which I didn't know other people had so here's what I'd suggest doing before each race!

    1) DO NOT RUN IN 144HZ. This was the cause of a number of game crashes for me. I currently use a 144Hz monitor but set the game to run at 100Hz as it's a known issue that this causes problems... my knowledge might be out of date regarding this, I don't know if it's still an issue or whether it was patched. I still don't do it though...

    2) Huge change - Disable any secondary graphics card. On-board graphics, check if you have it and disable it before a race. This is a massive stuttering issue; without doing it I get game pauses/stutters 4-5 times a lap. Disabling it, I'll probably get one serious spike (3-5 seconds) once every 2 races.
    • Hit windows key
    • type Device Manager (and enter)
    • expand 'Display adapters'
    • Right click and disable device for your secondary card.
    3) Unplug 2nd/3rd monitors. No idea why this game is any different to others but extra monitors == extra stuttering for some reason here.

    4) Turn off un-required processes. Ctrl+Shift+Escape. Go to the processes tab. Do not leave Edge/Chrome/Firefox running whilst racing. I also actively go through and turn off Cortana, f.lux, Hyper-V, Oculus, Office, Skype, SVN. Your programs will vary but if you know what a program does and don't want it on, end task before racing. Flux and Oculus caused quite large crashing issues for me...

    5) Turn off un-required services. Ctrl+Shift+Escape. Go to the services tab. There's a lot of stuff in here which shouldn't be touched so do not turn anything off if you don't know exactly what it does but you may find things such as adobe updates, XBox Live stuff and other updating software sitting here which you can pretty much permanently disable.

    If anyone wants me to look over a list of their services, let me know (don't post the list publicly). It won't just help with F1 but for some reason, this game is a lot more sensitive than others to all this stuff.

    Hope this helps...
    Mark.
     
    • Like Like x 3
  2. [DNA] Rico Nosberg

    [DNA] Rico Nosberg
    Premium

    Messages:
    233
    Ratings:
    +54
    I run 144Hrz since the start, no problems at my end of gaming.
    I only have some hickups when people connect to the host or leave the race.
    I am pretty sure my gamer works fine, its more an issue since the 1.08 patch.
    :)
    All this work and then turn 1 you get hammered by a lewis wannabee! :laugh:
     
  3. [DNA] Rico Nosberg

    [DNA] Rico Nosberg
    Premium

    Messages:
    233
    Ratings:
    +54
    New issue came up just now!

    [​IMG]
     
    • Haha Haha x 1
  4. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Hold on so... well you've... nope, I've got nothing.

    Glad to hear the 144Hz issue isn't there anymore, the rest will have an impact as least though! :)
     
  5. Pretend3r A

    Pretend3r A

    Messages:
    165
    Ratings:
    +67
    Been tinkering with some game settings, nothing makes a ****ing difference....:(:(:mad::mad::mad:
     
  6. robinf1

    robinf1

    Messages:
    55
    Ratings:
    +21
    You got this problem only with F1 2016? Or also with other games?

     
  7. jonaslynnerup

    jonaslynnerup

    Messages:
    15
    Ratings:
    +6
    do you know when it was your last time you updated you graphics driver? maybe there has come a problem from the latest update?
     
  8. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    It is very odd; I suspect this version is more of a console port than F1 2013 was at least because upping the graphics actually improved my frame rate. Okay my 3770K is a bit older now but this isn't meant to be a CPU bound game so there is no obvious, reasonable explanation for it. Shame none of the things above have helped. :/
     
  9. Coffer

    Coffer

    Messages:
    207
    Ratings:
    +41
    Almost certainly, since the optimization seems to be completely and utterly missing compared to 2015. The nearly nonfunctional AA is also a hint.
     
  10. [DNA] Rico Nosberg

    [DNA] Rico Nosberg
    Premium

    Messages:
    233
    Ratings:
    +54
    Mark i am on a x5650 xeon server processor from 2008, so i do not think it's your 3770K :roflmao::roflmao:
     
  11. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Apparently one thing they've done very well in this engine is hyperthreading which completely baffles me. Your dated Xeon might actually be more powerful than gaming i5's/i7s on this, lol. :D
     
    • Agree Agree x 1
  12. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Another thing to add to the stuttering issue - if you use headphones and have speakers as well, unplug the unused speakers and turn off any conflicting audio software.

    Any feedback on whether these tips helps anyone would be appreciated, it's the only way to know if I'm talking nonsense or not...
     
    • Agree Agree x 1
  13. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Another quite specific one - if you've ever installed SQL on your machine, make sure you shut down those background processes in task manager before starting... basically anything starting with 'SQL server'.

    "sql server windows nt - 64 bit" was using between 15% and 60% of my CPU for some weird reason which has caused stuttering in an unrelated application but if F1 was running, it would have caused issues as well.
     
  14. Avallac'h

    Avallac'h

    Messages:
    46
    Ratings:
    +31
    That must be specific to your machine as i'm running SQL server all the time while playing F1. Never have had any issues with it. Neither do i have any with installed mods. I have cleanly installed f1 tho, just to be sure it doesn't cause any issues for others.
     
  15. Mark Saunders

    Mark Saunders

    Messages:
    445
    Ratings:
    +224
    Yeah, I've been monitoring it again today and that process hasn't done anything so I have no idea what caused it to start spiking. I couldn't trace anything it was doing and it wasn't updating or anything so from now it's just another thing on the list to shutdown before trying any time critical gaming.
     
  16. Jas Verstoppen

    Jas Verstoppen
    DNA Racing Premium

    Messages:
    349
    Ratings:
    +53
    Codemasters is such a shitty Company for those problems.
    They shouldn't be there at all. Period.
    We must be like loonatics who do everything to have a stable game. Ironic.
     
    • Agree Agree x 1