1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC [Recommendation] Use AntiMicro for D-Pad support

Discussion in 'Assetto Corsa' started by Peter Kerényi, Jul 15, 2016.

  1. With the 1.7 patch we got many new mappable functions. AC however doesn't support D-Pads on wheels. The recommended software to overcome this issue was always X-Padder. While I could make it work for Win10, with each startup I had to reconfigure it, it didn't start with Windows despite set up to, etc. Furthemore, it's a payware program, although it's last freeware version 5.3 is available to download, but you might run into compatibility issues depending on your system. So I started looking for alternatives.

    The best one I found is AntiMicro. It's free, it's got a simpler, cleaner interface, starts with Windows, perfect for the job. Just set it up to start automatically and close to tray.


    I hope I could help :) Capture.jpg

    Just map a keyboard button to the D-Pad buttons in the software, like I have Up/Down/Left/Right Arrows on the picture, in the game menu map e.g. MGU-H to Right Arrow and by pressing the D-Pad button which is associated with Right Arrow will switch your MGU-H mode in game. Same method as X-Padder.

    Edit: Don't forget to enable combining keyboard and wheel input in the game controls settings Untitled.png

    If you tried this and like the results, please comment so the thread doesn't get lost into oblivion and more people can see it and improve their AC experience :)

    Edit 2: About the "freewareness" of Xpadder
    Last edited: Sep 30, 2016
    • Like Like x 9
  2. Thank you so much for this tip. Will try asap.
    • Like Like x 1
  3. Mee too!
    • Like Like x 1
  4. Thanks for the tip but for some reason it doesn't work for me, I can map the button in the launcher but once I actually start the sim the buttons don't work, anyone have any ideas as to why?
  5. Umm, when you install the program, you launch it, then if you set it up and close it with X it doesn't go to tray but fully closes. There is a setting in the preferences "close to tray" than it keeps running in the background after closing it with X.
    (I ran into this problem when I first tried it)
    If not would you please tell us some details which buttons you map in the program and in the sim?

    Edit.: Another idea. Did you enable combining keyboard and wheel input in the controls settings in the sim?
    • Like Like x 1
  6. Didn't have the combine keyboard and wheel option ticked, doh. Thanks very much for the help :)
    • Like Like x 1
  7. You're very welcome. I'm glad I could help :)
  8. Great tool, thanks for sharing
  9. thanks!! exactly what i need.
    • Like Like x 1
  10. Can't get it work with clubsport v2, i mapped the buttons for WSAD in the app but in AC controls i can't assign command to a to wheel button, nothings happens. Beside the commands there is also tab with keyboard. I can assign it with that but nothing happens on track.
  11. Oh maybe thats why i am having issues.
    • Like Like x 1
  12. Where is that option, i really looked everywhere lol

    Attached Files:

  14. haha thanks, how the hell was i meant to know that :)
    • Like Like x 1
  15. Edited the opening post so less people will run into this problem :) Is it working now btw? :)
  16. After my initial issue with the ticked box thing it now works great, could really do with getting a cheap button box, too much stuff to bind now and using a PS3 controller is hardly optimal :)
    • Like Like x 1
  17. If you have enough place get a cheap flight joystick. Aside from the added buttons next to your wheel, you will get an analogue handbrake as well! ;)
  18. Hm thanks for the suggestion of antiMircro but it seems like i cant get it to work :(

    And with that i mean that i got the dpad to work ingame but when i start antiMicro my T300 loses all FFB until i fully close that application again.

    I have the same problem with xPadder. So it works but its not really usable. Anyone had that problem before? and maybe even someone found a solution to it?
  19. Hmm that's very strange. I have a T300 as well and neither AntiMicro, neither X-Padder did this to me. As a standard procedure, try updating your firmware and driver first.
    Does it see your wheel properly as a T300? Capture.PNG
  20. Yep perfect, was badly needed.
    • Agree Agree x 1