1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

RBR_Rx plugin "error mesh file not found"

Discussion in 'Richard Burns Rally' started by salkinator, Aug 3, 2014.

  1. When trying to load BTB Finland tracks by the savo stage team my RBR_rx plugin throws the error "error mesh file not found for..." every object when it tries to LoadGeometry(). Log looks like this:
    C:\Richard Burns Rally\Plugins\rbr_rx.dll:
    base: 10000000
    size: 0006F000
    entry point: 100379BA
    C:\Richard Burns Rally\RichardBurnsRally_SSE.exe:
    base: 00400000
    size: 01347000
    entry point: 00000000

    version ok.
    LoadTextures()
    LoadEffects()
    LoadMaterials()
    LoadMeshes()
    LoadGeometry()
    error mesh file not found for Object_0
    error mesh file not found for Object_1
    error mesh file not found for Object_2
    error mesh file not found for Object_3....
    This keeps going for every object in the track folder. Anyone know why this is happening? I am able to get most tracks to work, just any of the tracks from the savo stage team have this issue. Please advise! I really want to be able to race Ouninpohja and some of the stages of this years NORF. Thanks in advance!
     
  2. I can't say I know why that is happening just because I never have any kind of issues with RBR, but that hasn't stopped me writing in sentences before.

    Now, I guess you are referring to BTB Finland country pack for RSRBR, and if that's the case, perhaps you should simply download and install the pack once more. All I know is that with a non-corrupt pack everything should be 100% (apart from some odd loading errors here and there, of course).

    It may not end here but this should be start before anything else.
     
  3. Thanks for the swift reply. So I'm not sure if im the only one whos figured this out, but i run RBR on my Mac using a wineskin wrapper. I eventually plan to build a pc game rig along with wheel and what not, but as for now I just enjoy doing some rallying with my xbox 360 controller.

    So, that being said, I havent been able to get the RSRBR mod to function through the wrapper. I can get the mod, updates, and all packs installed... however once they are installed Rallyesim crashes when i use any of the arrow keys to navigate through the menus. Also, when i simply launch the RScenter, and try to play "alone".. I am able to select my tracks, conditions, car... etc. But, the RSRBR buttons, or "GO Race" buttons... (ANY Button) fails to launch the game. It's like they dont even work, because literally nothing happens. I have tried installing the mod, patches, cars and tracks numerous times on fresh installs of RBR and I always run into the same problem.

    Since I cant get RSRBR working through the wrapper, I have resorted to just use RBR (patched to 1.02) with the rbr_rx plugin and have also installed the "training day" plugin, which are both quite nice because you can quickly chose a track and car and go do some driving. And this is where I have issues. I manually put RX BTB tracks in the RX_Content > Tracks folder and access them through the plugin. Most tracks I've downloaded and placed in the tracks folder work fine (besides the occasional random odd loading error) however, any of the finland tracks have the problem loading as described in my original post. When it comes to LoadGeometry() all the objects fail to mesh. This results in the map having no ground and once the loading completes the car just falls through space indefinitely.

    Thanks again, and anymore insight you have on the problem is greatly appreciated!
     
  4. Ok, that's clear.

    I don't know a thing about Macs - hey, I've seen them only in magazines I don't subscribe - but I would find it surprising if RSRBR worked on a Mac, just because of its relatively complex system (compared to normal RBR, that is) that can bring up issues even in Windows environment. That symptom you describe reminds me of how things go with RSRBR when one doesn't change the DEP settings in Windows: nothing happens when you try to launch exes and so on.

    Anyway, I find it mystifying that the Finnish BTB stages give you that much trouble, because in essence they're not different to any other stages out there. I'd say that everything points to a wrong folder structure --> leading to missing files when loading. I cannot think of anything else. So try comparing the stage folders in \RX_CONTENT\Tracks to see if the structure for Finnish stages are different to ones that work fine.

    I presume you have downloaded the stages one by one from the following links?

    2009: https://www.dropbox.com/sh/dz94qabgik0w0gj/52L2p532Gy
    2010: https://www.dropbox.com/sh/q0uojidna90fj9s/AlBks0_u9h
    2011: https://www.dropbox.com/sh/macmdh4iu76h3ji/_V6MB9yRC1
    2012: https://www.dropbox.com/sh/1oed3xnntmoslzf/j4LTIShiAu
    2013: https://www.mediafire.com/folder/1u2r3kfyw6yhe/2013 BTBfin RX Track Archive
    2014: https://www.mediafire.com/folder/z9ejp79pofol4/2014_BTBfin_RX_Track_Archive
     
    Last edited: Aug 3, 2014
  5. Indeed. The tracks I have been downloading appear to be the same as those that you've posted and there are some very bizarre things going on. I've checked the file structures of all the tracks that work to those that do not work and they appear to be exactly the same. But, for example, the stages from 2009 work and the stages from 2010 to do not. At first I started to think maybe my rbr_rx.dll plugin was only able to work with 2009 files, but I am able to get some of the tracks from 2011 to work (So WEIRD! Mainly I would love to drive the Ouninpohja stage and experience it, but I havent been able to get any version of that track to work)

    Also, I definitely experience a drop in frame rates with this tracks (probably due to the higher polycounts than the original RBR tracks) So i'm starting to think maybe i just need to enjoy the standard RBR with the real physics mod applied until I manage to get RSRBR working.

    I'm going to try and do another fresh install of RBR into a brand new wrapper and see if i can get RSRBR working. Is the newest RSRBR (2014) the most stable? or is it worth trying to install one of the older versions?

    Also, you mentioned the DEP settings for windows. What are the correct DEP settings for RSRBR? And, wineskin allows me to emulate any version of windows so what is the best one to use? Should I use XP? Windows 7 or 8...etc? Once I get RSRBR installed I can hopefully troubleshoot the DEP settings and get it to work with your help. Btw, wineskin also has utilities (called "winetricks") to help me update direct3d plugins and everything... so if there are some sensitives things with RSRBR in that aspect, I should be able to solve them.

    Thanks again!
     
  6. So, I have an update.

    In trying to install RBR and RSRBR 2014 all from scratch I ran into the same problem I described, where the base version of RBR crashes when trying to use any keyboard input besides enter. (Trying to navigate through menus using the arrow keys or trying to drive... which is also weird, I can get all the way into the first rally school stage by just hitting enter through all the initial menus.. but as soon as i try to drive the game crashes)

    Since I was unable to get RSRBR to work, I deleted everything and started from scratch once again to tackle the RBR_rx problems. And I have come to a conclusion.

    The RX map files that I am able to launch in rbr_rx plugin are the map files that have a folder inside the 7zip file. When I download a track that simply has the files in the 7zip folder and i export them to a folder i have created... I run into the geometry mesh problem. This is very weird and beyond me, but could it be that when I'm extracting the files that everything isnt getting transfered properly?

    Hopefully thats clear, and we can figure out how to get this shiz to work!
     
  7. I'm not sure if I understand you correctly about that 7zip part, but all in all, it is possible that your software (what is it, by the way?) isn't able to extract all the files, wouldn't be the first time in the history of, eh, unpacking. I could go into detail, but better not (except to say that hopefully you're not using lzarc).

    If I'm honest, I don't know where to begin with your problem, but is this the rx_plugin pack you've installed? If yes, that's good. https://www.dropbox.com/sh/1oed3xnn...UGIN COPY THIS FILES IN RBR INSTALL FOLDER.7z

    - In every single BTB stage directory there has to 4 folders (CACHE, FX, Objects and Textures) + 8 .ini files.

    - You mentioned Ouninpohja earlier, so let me tell you that the most recent release of that stage (from 2013) contains those 4 mentioned folders, 8709 files in all, and it's 145 MB (152 338 326 bytes) in size. Now, you may have more files and even folders in there, depending on where you've downloaded Ouninpohja, but you cannot have less. Maybe these "stats" will help you investigate further, but I doubt it.