1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Random black screen during on track session - SRS message in background

Discussion in 'Assetto Corsa' started by Paul Jeffrey, Jul 18, 2016.

  1. Paul Jeffrey

    Paul Jeffrey
    Sim Racing News Editor Staff Premium Member

    Hey guys,

    I've found an issue in yesterday's RD MX-5 Cup race I want to share and discuss. Its a new one on me and I've never heard of it before, but I wanted to see if anyone knows how to fix it or if you have the same issue.

    During on track sessions (it happened twice in practice and also on the last lap too) I had a black screen for around 3 seconds or so then then game came back on again. Immediately following the black screen FPS dropped by around 30 (although I was in the last section of the lap so I don't know if it would stay bad fps or clear itself). Everything else was normal, no noticeable issues etc.

    I noticed if I cntrl/alt/tab to spin through on screen pages I had a SimRacingSystem error message (forgot what its says now, but it game me an option to click 'OK' to remove the message).

    Now after the issue in practice, I deleted SRS and all files I could find, so when race start came I didn't have it installed (however the SRS logo and options still appeared in AC - perhaps I need to delete more files within AC itself?).

    So that's my little issue... hope anyone can share their experiences with anything similar and I can get to the bottom of the problem (and hopefully help others with a similar issue). I remember pre race another of the guys mentioned some SRS issues causing him some problems, and I think I heard someone on TS say they had the same problem at a similar time to me in the race, however at the time I was clenching my backside trying to keep the car on track so maybe I misheard :)

    Any help is appreciated :) Thanks.

    Btw, I'm running triple screens with a 980ti and FPS locked on a solid 60fps.

    Cheers
     
  2. If it's the same as mine, it's something about clicking OK to refresh SRS. It certainly didn't happen before the current "reset." Also it happened to me during a single player practice session.
     
    • Like Like x 1
  3. Paul Jeffrey

    Paul Jeffrey
    Sim Racing News Editor Staff Premium Member

    Yep that's the one @drovek ! So you get the black screen too?

    I'm going to pop up on the rig later tonight and try a more substantial uninstall of SRS and try to clear the whole thing out of AC and see if that makes a difference....
     
  4. Yup, pretty much black screen and that dialog box. It's happened a couple of times only, and in offline sessions. (Haven't tried online at all lately.)
     
  5. Don't know if related, but I get also a blackscreen in benchmark mode for a brief instant after it starts.
     
    Last edited: Jul 18, 2016
  6. Tobias Röhner

    Tobias Röhner
    Germany's greatest Indycar Fan. Staff Premium Member

    Yep, happened to me with SRS too.
     
  7. Paul Jeffrey

    Paul Jeffrey
    Sim Racing News Editor Staff Premium Member

    Ahh looks like SRS is the problem then (more RD club racing and less SRS people... ;) )..

    Ok thanks guys, looks like the solution might be to dig around in the files some more and try to delete any reference to SRS either as standalone or within the AC folder.

    Deleting SRS wont be a big loss to me really, it became the George Forman grill syndrome anyway, awesome idea that I used loads for a couple of weeks then forgot about it totally and never used again :D

    Cheers
     
  8. +1 here, a 'Refresh SRS' window message appears w/c causes the black screen. FWIW, I didn't have to delete/uninstall it, I just disabled it in General->Options. So it's easy to re-enable when you want to use it.
     
    • Like Like x 1
  9. Glaurung

    Glaurung
    Premium Member

    Confirm me too this issue.
    Disable the SRS app as Joel've said.
     
    • Like Like x 1
    • Love Love x 1
  10. Paul Jeffrey

    Paul Jeffrey
    Sim Racing News Editor Staff Premium Member

    Oh nice one, thanks for the advice guys :thumbsup:

    I'll have a check tonight assuming the unusually warm UK weather calms down a little so I can get in my rig without melting :roflmao:

    Cheers!
     
    • Haha Haha x 1