• "Frankly, I know what's wrong but don't know how to fix it." - Bernie Ecclestone.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. The 2017 Formula One Monaco Grand Prix. Join the conversation here.
  3. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Raceroom not loading with Steam!

Discussion in 'RaceRoom Racing Experience' started by Angeltheartist, Jun 16, 2016.

  1. Angeltheartist

    Angeltheartist
    Premium

    Messages:
    165
    Ratings:
    +23
    I uninstalled it last night . I would click on it and nothing would happen it would not load , could not verify cache absolutely no response.So I uninstall . Once I did that I restarted my PC signed into Steam and it was not in my library . So I tried to install from the Raceroom website and it took me straight to Steam . In Steam it showed as game in my library but it was not in my library. I have uninstalled Steam and reinstalled and still the same result. All my other games thru Steam work as they should.
     
  2. Kenny Paton

    Kenny Paton
    Staff Premium

    Messages:
    6,041
    Ratings:
    +2,725
    Have you previously associated the game with Steam as S3 advised?
    https://forum.sector3studios.com/index.php?threads/important-change-is-coming-please-read.5610/

    It may be that they are applying the patch and that's why you're having issues.
     
  3. Vangelis Parginos

    Vangelis Parginos
    Premium

    Messages:
    1,098
    Ratings:
    +1,413
    Search the game at steam store and press play, thats gonna install the game.
    Its a free to play game so when you uninstall it, you wont see it at your library.
     
    • Like Like x 1
  4. M D Gourley

    M D Gourley
    Premium

    Messages:
    296
    Ratings:
    +177
    Thanks for that info as I was searching for it and could not understand way it was not in my list...thanks again
     
    • Like Like x 2
  5. M D Gourley

    M D Gourley
    Premium

    Messages:
    296
    Ratings:
    +177
    What I did was uninstall that driver and reinstall the one that was working previously.:D