1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Racer won't connect to localhost (Can't free drive)

Discussion in 'Racer Problems & Fixes' started by camsinny, Jan 2, 2012.


    If you have a Bigfoot network card or use the Bigfoot Network Manager, be sure to set racer to priority 2 or lower in the applications tab.

    Original thread is below.

    So as not to clog up the release thread and in case anyone else has a similar problem thought I'd post this here, Mods feel free to move the posts from the other thread.

    So I bought a new PC and was looking forward to being able to play Racer at good FPS, however it won't run.
    QLOG reports the following:
    Mon Jan 02 13:11:08 (INFO): [racer/1248] --- application start ---
    Mon Jan 02 13:11:08 (INFO): [racer/1248] Racer version: 0.8.38 (Dec 27 2011/14:02:49) - customer: Internet
    Mon Jan 02 13:11:08 (INFO): [racer/1248] Physics engine: NEWTON v2.34
    Mon Jan 02 13:11:08 (INFO): [racer/1248] Safety changed to: SAFE
    Mon Jan 02 13:11:11 (INFO): [racer/1248] Loading track 'carlswood_nt'
    Mon Jan 02 13:11:12 (INFO): [racer/1248] QNClient:Connect() attempt to localhost:25000 (RNetwork)
    Mon Jan 02 13:11:12 (WARN): [racer/1248] QNClient:Connect(); failed to create enet peer; out of connections (RNetwork)
    Mon Jan 02 13:11:12 (WARN): [racer/1248] QNClient:Connect(); failed to create enet peer; out of connections (RNetwork)
    Mon Jan 02 13:11:12 (WARN): [racer/1248] QNClient:Connect(); failed to create enet peer; out of connections (RNetwork)
    Mon Jan 02 13:11:12 (WARN): [racer/1248] QNClient:Connect(); failed to create enet peer; out of connections (RNetwork)
    The racer.nl docs mention that I might have to "play with the firewall settings" however I'm not currently running one.

    From the other thread, DavidI suggested a few things, here's what we've ruled out:
    • Firewall
    • Anti-Virus
    • Hosts file
    • Port Forwarding
    It will run if I disable the network adapter (still runs if I re-enable it while racer's running) or unplug the network cable. These however are not solutions, only workarounds. I'm looking for a solution.

    Any suggestion I'm willing to try. Within reason. I'm not going to submerge my PC...
  2. can u ping 'localhost' from a command prompt? Should respond with
  3. The only thing I've needed to do on my Win7 box here is in Control Panel, Admin Tools, Windows Firewall with advanced Security; I've added rules named 'any' to inbound & outbound rules that allow anything to anything on any port. I can get away with that because among other things I'm developing a firewall solution, and have a very good firewall on my internet connection already, also my PC's joined to a windows AD domain (run a few servers here lol) and everythings locked down pretty tight thru windows policies etc.
  4. Pinging localhost works just fine, less than 1ms response as expected.
    I also tried pinging on localhost:25000 but I don't think that's how ping actually works, didn't expect it to work anyway. Doesn't ping use a port number of its own to do its thing?

    Tried your firewall rule but it didn't have any effect.

    There is a 2nd networking card in the pc, a wireless one which I used initially to connect to the internet while I didn't have a long enough ethernet cable. I'll try taking that out later today when I buy the new HDD I've been waiting for.
    I have a feeling it may have something to do with that, even though it's currently disabled.
  5. Yes, it may well have something to do with it. I'm assuming ur also using Win7?
    Ping technically uses ICMP protocol, which itself uses tcp port 23.
    If u want to try connecting to another port, telnet is your freind.
  6. Well my new monitor just arrived. So I kinda need to get this working now.
    I can't believe how huge this thing is.

    I'll try removing the other card now.

    Uh..so that didn't work.
    It's an onboard LAN port. My mobo is a Gigabyte G1 Assassin 2 - it has a bigfoot e2100 (chip?) but I can't seem to install the driver without the silly utility that it comes with. I have a feeling that could be an issue, that program might be messing with something it should be.
  7. Never used a bigfoot chip, I've thought them overpriced for the gains; but I've only considered addin cards.
    I tend to stick to Intel, Broadcom, & realtek chipped ones if i can. As they are the most widely used (esp corp/enterprise), they have the loudest complainers getting the issues fixed in their drivers.
    Have you told windows it's a private (home orbusiness) or public connection?
  8. Private.
    For now I've just setup a batch file to disable and enable the LAN. At least I can run racer then and leave it in the menu and still use everything else.

    Thank god I've got the new i7 and 16GB of ram.

    I have a feeling it is that stupid bigfoot thing cause apparently there was an issue with WOW too in which it wouldn't launch. I might have a crack at their forums, but I'll probably just grab an old card from a PC at home somewhere. It's so much hassle and there doesn't seem to be an answer in sight :(
    Unless Ruud knows some issue...Ruud?
  9. I'm sure bigfoot got bought out by someone recently, can't remember who though, I'm such a help lol.
    I'd tend to agree the Bigfoot network card's your achilles heel.
    Chuck any NIC you have in it, with just an internet connection even connected to fibre you'd be hard pressed to run a 10Mb NIC hard,
    100 & Giga's are overkill for internet PC's.

    I'm lucky in that I run an IT co, I generally have a spare 'something' lying around somewhere to get me going when I need to.
  10. It's a shame that Racer NEEDS to connect to itself to work.

    I feel your pain from all those years ago when I had to do the same as you to make it work. Back then I was on dial-up, so messing with the LAN wasn't such an issue when I wanted to run Racer...

    PS, have you tried logging on to a Racer internet game hosted by someone else? We could try that if you wanted?

  11. I tried doing a local LAN race. I hosted on the computer that would actually work.
    It wouldn't connect to that either.
    Ruud, if you're looking at this, are there any other diagnostics racer side that I can boot up to see what's going on?
  12. I think the only way to prove you have an issue with the bigfoot card is by putting another adapter into the pc. A cheapo realtek based 100TX would do (handy to have one lying around spare anyway).
    Do I understand this all correctly? Th bigfoot card works for web browsing, can connect to other PC's via windows networking, but has an issue only with Racer & WoW?
    Considering they promote this card as being especially good for WoW, thats a HUGE oversight on their part
  13. That's correct. I can play other online games too, BF3 and the such work, it's only racer that seems to have a problem. I don't play wow but apparently in november of last year there were issues with something bigfoot and the wow launcher not launching the game. When I go home I'll have a look for a cheapo NIC. I'm willing to put money on it working.
  14. Yes, i would put money on it too. I always wondered about the Bigfoot stuff in real life usage, if they REALLY had something good I would've thought it would have done a lot better than they seem to, leads me to believe they have a lot more marketing hype than real world advantage over your garden variety Realtek's & Marvels.
    I wonder what it's issue with Racer is?
    I was just looking thru the Bigfoot 2100 Manual, it has support for settings per application, like nVidia drivers do.
    Do you need to add racer.exe as a new application profile? maybe you can then 'allow' it
    'Blocking or Allowing Applications

    Killer™ Network Manager permits you to block certain applications from
    accessing network bandwidth. This prevents unwanted applications
    from accessing the network when you don’t want them to and frees up
    available bandwidth for other applications.'
  15. Yeah I don't use that. Why bother throttling apps? I have it turned off, though for science's sake I did try enabling it and setting it to level 1 (don't throttle) with no change in performance.

  16. [Borat] GREAT SUCCESS! [/Borat]

    So I was doing a little searching on the net for a linux driver and stumbled on something in the bigfoot forums:

    That worked!
    Then the bigfoot guy suggested setting Second Life to priority 2 in the application manager, that also worked for racer!

    So I can play without having to disable the connection! Yay!

    Thanks for all your help David, and everyone else who chimed in too!
    • Like Like x 1
  17. Glad to hear it.