• "Bite off more than you can chew and then chew like hell." - Peter Brock
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Racer v0.8.28 released!

Discussion in 'Racer' started by Ruud, Dec 22, 2010.

  1. Ruud

    Ruud
    RACER Developer

    Messages:
    592
    Ratings:
    +58
    Since X-mas is still so far off. ;-)

    Get it at http://www.racer.nl/download/racer0.8.28.zip (83Mb)

    This one does seem close to v0.9, except perhaps for some replay enhancements.

    Changes (some already posted in the v0.8.27 thread):
    - Minimap was painted even if no splines were present
    - SMD chase cam shadow focus is now on the car, not near the camera itself
    - 3rd shadow split distance reduced to 500m for detail. Last split is now faded out.
    - Large car CG offset could get some 3D objects culled incorrectly.
    - 'Select car' screen gave car.ini errors which were incorrect (due to fast loading of only the first part of car.ini)
    - Force feedback was passed to steering wheel even if steering was not done through that wheel
    - resolution.render_aspect didn't work; fixed
    - Shadowmapping tweaked again for even less Z correction
    - Pacejka Player tweaking lambda values wasn't correct for MF5.2 curves
    - Backfire 'likeliness' removed until we get better turbo behavior (>v0.9)
    - 'grip 0.5' appeared to also reduce engine torque. Fixed (doubly stored data in the code, as if grip=1).
    - Only the first 2 splits are blurred
    - Autoclutch RPM now slams the clutch harder around the optimal RPM. Works to get at the optimal torque rpm
    when driving off, although it is a bit harsh. Seems ok when I look at g-force graphs though.
     
  2. krsman3d

    krsman3d

    Messages:
    75
    Ratings:
    +3
    The gear and fps readouts are too big and disappear sometimes before the start of the race and F1 doesn't do anything.

    The autoclutch now makes faster takeoffs possible, but it is not nice in the higher gears where it seems too harsh as you said.

    Nevertheless a great version Ruud! v0.9 is just around the corner. :D
     
  3. Mr Whippy

    Mr Whippy

    Messages:
    2,977
    Ratings:
    +456
    Hi Ruud,

    Not had a play yet... but.

    Another thing I'd like to see for v0.9, if at all possible, is for ini.exe to be able to edit strings.

    Ie,

    susp0~susp_front

    Is impossible to change with ini.exe

    Can we make it so we can do things like

    susp0 "susp0~susp_front_stiff"

    So we can move from a susp_front >> susp_front_stiff by running a batch file? (I'm doing lots of car config changes via this method)

    This means you could define a load of sound sets in the car.ini file, and then simply ask the accelerate_in tree to point at different sound sets, so you can easily swap to a sports exhaust, which adds 5% more torque (engine.max_torque "1.05"), adds a different exhaust graphic (extra model), and changes the sound of the car (accelerate_in~accelerate_mod_exhaust)


    No problems if not, but it's a feature that would be really cool to see since we have no way to do these car settings. This is the only thing stopping ini.exe being really very powerful for this kind of thing!


    Will grab when I get home and take a look :D

    Dave
     
  4. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0
    Crash on car select menu:

    (FATAL): [racer/5152] Exception 0xC0000005, flags 0, Address 0x00552E65
     
  5. KS95

    KS95
    RACER Moderator

    Messages:
    2,416
    Ratings:
    +196
    I'm very intrigued... :)
     
  6. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    hmm...ok...on this version i like:......... i don't like: autoclutch handling... and can you please take a look to the QLog...i get this many times...

    THX
     
  7. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0
    I'm also getting weird transparency issues with this version.
     

    Attached Files:

  8. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    Messages:
    1,417
    Ratings:
    +286
    May be you use the cg version and a car with a OLD shader?
    i get this too...

    screenshot009.jpg
    ...B6 with OLD shader and Racer CG Version.....
     
  9. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0
    Using CG shaders makes cars really dark, usually completely black. I've missed a lot recently, anyone fancy bringing me up to speed, in a PM, with how to give a car CG shaders that don't look awful?
     
  10. Eholov

    Eholov

    Messages:
    223
    Ratings:
    +75
    me too please... :)
     
  11. KS95

    KS95
    RACER Moderator

    Messages:
    2,416
    Ratings:
    +196
    If the CG shaders are dark, that's because it's a non-cg track. A cg skydome fixs it, right? Correct if I'm wrong, I have little knowledge :)
     
  12. Some1

    Some1

    Messages:
    547
    Ratings:
    +188
    Something weird is going on with the shadows on that box. Hmm, either it is the setup (racer config, track or car) or there is something fishy in the shadowmapping shaders...
    [​IMG]
     
  13. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0
    Are there any CG tracks?
     
  14. Splashonda

    Splashonda

    Messages:
    815
    Ratings:
    +51
  15. krsman3d

    krsman3d

    Messages:
    75
    Ratings:
    +3
    Are shadows supposed to look like this?

    [​IMG]
     
  16. Raphael Buthmann

    Raphael Buthmann

    Messages:
    699
    Ratings:
    +272
    - Autoclutch RPM now slams the clutch harder around the optimal RPM. Works to get at the optimal torque rpm
    when driving off, although it is a bit harsh. Seems ok when I look at g-force graphs though.


    I love this part lol
     
  17. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0

    Attached Files:

  18. camsinny

    camsinny

    Messages:
    479
    Ratings:
    +21
    ^ Are you sure you're running the CG version (not the no-cg version)?
    And if you could post your PC specs it would help too :)
     
  19. FiftyOrange

    FiftyOrange

    Messages:
    492
    Ratings:
    +0
    I'm definitely running the CG version. CG has always run fine for me. The last version I was using was 0.8.18, I've just upgraded to 0.8.28 and now it's all dark and weird. PC specs are i7, 24GB RAM, and a nVidia 9800GT, also 64bit OS if that makes any difference.

    Worth mentioning: default MurciƩlago/Baja and default Carlswood together work fine. Everything else is weird somehow.
     
  20. Mr Whippy

    Mr Whippy

    Messages:
    2,977
    Ratings:
    +456
    Nope :D

    Hmmm, weird. I wonder why that isn't working then...

    Dave