• "Bwoah." - Generic Kimi Quotes.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Racer 0.8.20: Black screen

Discussion in 'Racer Problems & Fixes' started by attc, Sep 21, 2010.

  1. attc

    attc

    Ratings:
    +0
    Hello

    I am having trouble with the newest version of Racer. When i start the racer.exe or racer_nocg.exe the start menu is just black. The game is working normally, there just isn't anything at the screen. If i for example start the game and accidentally click on the free ride button, the game loads and race starts, then there is dials, "console", FPS- and gearcounter, "Lamborghini logo" and the red arrow(indicating player position in map) visible but nothing else. Game sounds to be working fine, i can change gears and accelerate. It doesn't matter if i am running fullscreen or in windowed mode, the screen just stays black.

    QLOG says the following:
    Tue Sep 21 20:56:00 (INFO): --- application start ---
    Tue Sep 21 20:56:00 (ERR): DFBOTexture; frameBuffer status not complete (Unsupported framebuffer format)
    Tue Sep 21 20:56:00 (WARN): DGPUShader:Load(data/renderer/fullscreen_shaders_hdr/bloom_f.cg): CG ERROR : "The profile is not supported."
    Tue Sep 21 20:56:00 (ERR): DFBOTexture; frameBuffer status not complete (Framebuffer incomplete, duplicate attachment)
    Tue Sep 21 20:56:00 (ERR): DBitmapTexture:FromBitMap(): OpenGL error (1281): invalid value
    Tue Sep 21 20:56:00 (ERR): DBitmapTexture:FromBitMap(): OpenGL error (1282): invalid operation
    Tue Sep 21 20:56:03 (ERR): DBitmapTexture:FromBitMap(): OpenGL error (1286): (null)

    I am running Windows 7 64Bit and nVidia GeForce 7900GT. Drivers are latest (260.63), tried with others as well, same problem.

    I haven't been playing Racer very often nowadays. Latest version before 0.8.20 i had is 0.7.3 and it is working perfectly. I also tried 0.8.19 and the same problem was there.
     
  2. luthobu

    luthobu

    Messages:
    1,120
    Ratings:
    +179
    Not sure if this helps, but try to edit racer.ini: turn off: bloom, all instances of fbo and shadowmapping (csm).
    About the "free ride" screen.. try changing the time in the console to get light.
    Otherwise I have been using 0815 for a while and it works fine for me. I can post my ini (for ATI x600) if you want.
     
  3. attc

    attc

    Ratings:
    +0
    Ok. I turned off bloom, fbo and csm in racer.ini and now i am able to see all the menus, yay! :) But still, the game itself is black. Now when i start race the screen is still black but i can see, in addition to those mentioned before, whole map and a mirror. Mirror is all white when the screen is all black. nocg works fine. Game also crashes when i press esc to return to main menu in race saying there is graphics problems, crashing happens in both normal and nocg versions. I also tried to set the time_of_day in racer.ini to different times but screen is still black.

    QLOG:
    Wed Sep 22 12:30:54 (INFO): --- application start ---
    Wed Sep 22 12:30:54 (ERR): DFBOTexture; frameBuffer status not complete (Unsupported framebuffer format)
    Wed Sep 22 12:30:54 (WARN): DGPUShader:Load(data/renderer/fullscreen_shaders_hdr/bloom_f.cg): CG ERROR : "The profile is not supported."
    Wed Sep 22 12:30:58 (ERR): DFBOTexture ctor: OpenGL error (1286): (null)
    Wed Sep 22 12:30:58 (ERR): DBitmapTexture:FromBitMap(): OpenGL error (1286): (null)
     
  4. luthobu

    luthobu

    Messages:
    1,120
    Ratings:
    +179
    Glad you got that far. But, there are still bloom and fbo calls in your ini:

    "Wed Sep 22 12:30:54 (ERR): DFBOTexture; frameBuffer status not complete (Unsupported framebuffer format)
    Wed Sep 22 12:30:54 (WARN): DGPUShader:Load(data/renderer/fullscreen_shaders_hdr/bloom_f.cg): "

    Tips: disable ghost, turn off fbo /everywhere/ (check mirror settings, it calls fbo for the textures) and then tweak the rest. That is the best I can do for you. Good luck, hope you get it to work :)
     
  5. attc

    attc

    Ratings:
    +0
    Oh yes, i ran config.exe to change to windowed mode. That put the bloom on. But anyways, i have tried to fiddle with the settings and only thing where FBO is enabled is motion blur. When i try to disable it or put any other method besides FBO, game crashes at startup.

    QLOG:
    Wed Sep 22 13:42:36 (INFO): --- application start ---
    Wed Sep 22 13:42:36 (WARN): DGPUShader:Load(data/renderer/shaders/empty_f.cg): CG ERROR : "The profile is not supported."
    Wed Sep 22 13:42:37 (FATAL): Exception 0xC0000005, flags 0, Address 0x004BB063
    (this dialog text is stored in QLOG.txt)

    OS-Version: 6.1.7600 () 0x100-0x1

    0x004BB063 d:\source\trunk\dev\src\libs\world\auto_exposure.cpp (line 116): WorldAutoExposure::Create()
    0x004C5427 d:\source\trunk\dev\src\libs\world\renderer.cpp (line 487): WorldRenderer::GetProperties()
    0x004B74C6 d:\source\trunk\dev\src\libs\world\scene.cpp (line 165): WorldScene::LoadSettings()
    0x0042391F d:\source\trunk\dev_racer\src\lib\rmanager.cpp (line 805): RManager::Create()
    0x004032A8 d:\source\trunk\dev_racer\src\mrun.cpp (line 1554): Setup()
    0x0040384E d:\source\trunk\dev_racer\src\mrun.cpp (line 1900): Run()
    0x004014EA d:\source\trunk\dev_racer\src\main.cpp (line 235): main()
    0x00401563 d:\source\trunk\dev_racer\src\main.cpp (line 242): WinMain()
    0x0053A48B f:\dd\vctools\crt_bld\self_x86\crt\src\crt0.c (line 263): __tmainCRTStartup()
    0x76173677 [kernel32]: (filename not available): BaseThreadInitThunk
    0x77799D72 [ntdll]: (filename not available): RtlInitializeExceptionChain
    0x77799D45 [ntdll]: (filename not available): RtlInitializeExceptionChain


    Thank you very much for your help so far, luthobu!