1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Race On: invalid game data

Discussion in 'RACE 07 - Official WTCC Game' started by kikie, Mar 19, 2010.

  1. That's the message I always get when trying to start Race On.

    I tried different DVD drives, checked RAM and still the game doesn't work. It works on an older P4 pc, so it's not the game.

    Help?
     
  2. Thanks

    Nobody annoyed me. :confused:

    EDIT: have been reading that other thread but I have this problem when I install the offline part of Race On. Steam won't even install at all. I alwas seem to get a .dll library thing error.
     
  3. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    And when you download the whole game directly from Steam instead of the DVD install ?
     
  4. Can I do that?
     
  5. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Yes, thats exactly what your game disc does also: installing steam and downloads the game afterwards :)

    1) Go to www.steampowered.com
    2) Download the steam client
    3) Open steam
    4) Create an account (don't forget to store your password somewhere)
    5) Click Games Tab
    6) Click Activate a Product on steam
    7) Fill in your code (should be in the box or on the disc?)
    8) Download the game
    9) sign up for the RD racing club :)

    When the download is finished you can either select to run it on or offline and the fun can begin :thumbup:
     
  6. what bram has forgotten is the most importent part

    9) sign up for the RD racing club :)
     
  7. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Actually i wrote that in white letters as a hidden message :)
     
  8. Thanks all for the help so far but I think it's hardware related.

    I can't reinstall XP anymore. I can't update the display drivers anymore. Getting errors in both cases. It could be a memory problem or a motherboard problem. I did a memtest 387 and all was fine according this test.
     
  9. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Can you post your system specifications?
     
  10. Lmao Bram i missed that one :D
     
    • AMD Athlon Duo core 2.8GHz 5400+
    • Kingstone 1066 DDR2 RAM => 4gig
    • nVidia 8500 GT
    • Gigabyte: GA - MA78G-DS3H motherboard
    • Since today (afternoon) a new DVD drive from Sony (warranty)
    • HDD 320 gig
    I want to upgrade this pc but I don't know what kind of graphics card/processor to get. I'm interested in nVidia's new DX11 cards. I have had a real bad experience with ATI.

    I got Race On working. I installed the new DVD drive, put the 4 gig of RAM in the other empty sockets and everything is working fine now, or should I say, for now.
     
  11. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Me too as it was a joke by adding it later :)
     
  12. pffft ;D