1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Race button disabled and 2 Lap restriction? (Evo+Race07)

Discussion in 'Bob's Track Builder' started by Dave Russell, Mar 19, 2013.

  1. Hi folks, I've searched everywhere for ages now trying to resolve these issues, I'm now hoping that someone here might be able to help and shed some light on this for me? :rolleyes: So thanks to anyone in advance!

    I tested the track in a primitive state and was able to join the track in all session modes. I then done some more work to it and now the 'Race' button is disabled preventing any player from joining the grid. Does anyone know what might be causing this? I've tried 'Clear All' and re-'Append Track' but made no difference :(

    Also, another problem is when in qualify, the car is being forced back to the pits just after starting lap 3 and the 'Drive' button then becoming disabled (i.e the same thing that happens when you get disqualified) I've seen this on other custom tracks except its usually lap 11 that it happens. Very strange lol

    I'm still not 100% on what data is stored in the AIW, was hoping its just the fastline, centreline, corridors, timing gates etc. If this is all it does, then for the purposes of testing to see whether it's the culprit, could I use the primitive version of the track and export to a temporary file name just to rob the AIW?

    Many thanks! :)

    EDIT: I managed to find the cause of the 'Race' button being disabled which was the garages being too far away from the pit line, when they are in a "stuck" state briefly when try to move them.

    And it is only during qualifying sessions that after starting the 3rd lap, the car is returned to the pits and the button 'Drive' is disabled, so any help on this would be great!
  2. Check you GDB settings. There are lines for ex qualy being only 3 laps etc. Remove all the lines that define session lengths and i mean all of them.. You may also want to increase the number of cars allowed on track, it's in the end of GDB file.
  3. Thanks Kennett! Will give it a try....;)
  4. I followed your advice but now the really strange thing is, after I deleted the lines that refer to session lengths etc., the track had vanished from the game (I looked in all groups). I re-exported again and in the end through trial and error, I found that just by opening the file in notepad and saving without changing anything also caused it to vanish? wtf? :O_o:

    If saving while not making any changes to it, then the only difference after saving would be the gap between the files last modified date of the aiw and cam files.. just sounds crazy, but what else is there? lol

    Stumped :unsure:

    EDIT: Using wordpad instead of notepad seemed to so the trick.. I guess there's unicode formatting or something similar within those files, that notepad can't translate.

    Thanks again for your help Kennett! ;)
  5. Usually it's the other way around, notepad does pure "ascii" (unicode..) txt files and in wordpad you need to be sure it doesn't include formatting.. But i have another tip for you: google and download Notepad++, all the cool kids use it (i've been using it since i think 2009 and it hasn't failed me once, also has been since then on the top five first downloads to a fresh windows install.. it is simply that good.) It's open source too, has line numbers and several options perfect for modders and coders still being as lightweight as MS Notepad.. :thumbsup: