1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

RACE 07 dedicated server help

Discussion in 'RACE 07 - Official WTCC Game' started by Yves Larose, Aug 20, 2008.

  1. Yves Larose

    Yves Larose
    Premium Member

    hi guys, i just installed the race 07 dedicate server and tried it but when i'm trying to connect it says that it can't connect so i was wondering if someone could help me please :thumb:

    thanks in advance
     
  2. Moved into the correct forum section :)
     
  3. do you show has having a ping of 5000 on the server list?
    firewall is blocking it, in that case...
     
  4. I Can set up a dedicated server and people can join but I can't seem to join why is this?
     
  5. are you trying to run the server and join it from the same ip address?
     
  6. Yep and I'm guessing i can't do that ?
     
  7. you should be able to if you change the port range in the server ini file, in gtr2 there was a help file to show you how to do it but i do not think there is anything similar for race07 but a quick look at the ini file and it looks like you would have to change these lines
    PortRangeBegin=0
    PortRangeEnd=0

    afraid i can not test as i have my dedicated server installed on another pc with a different ip address so have never had this problem.
     
  8. So would i have to change it to that or it needs to be changed from that?
     
  9. I've tried this and spent hours in the router trying to get it to work which i eventually did but any more than 2 or 3 cars and the lag was unbearable, you need a lot of bandwidth to run a decent amount of cars :( for what it's worth I turned off the firewall on the pc and set up a DMZ in the router :)
     
  10. You don't need to. I run a race07 online dedi server from my pc regularly and can connect to it without any changes.
     
  11. The problem is normally in the router!
     
  12. Exactly - its to do with port forwarding

    Click this and find your router
     
  13. the standard ports are TCP+UDP 48942 – 48957 and UDP 26900-26907 so you need to change it from that.
    i am not sure if you have to specify which ports within the ini file or if it will accept changing it to say +1
    For gtr2 you could specify the ports used within your plr file but with race07 it is slightly different.
     
  14. yes but if you have 2 systems sitting behind a router both trying to use the same ports then what system does the router forward the data too?
    This is why one system needs to change the ports used.
     
  15. Dietmar

    Dietmar
    Premium Member

    Do I need a second license for the server, especially when I run it on a separate PC?
     
  16. I have opened all of the necessary ports along with the steam ports but it's still doesn't work:(
     
  17. Dietmar

    Dietmar
    Premium Member

    Just tried it now myself.


    • Started the Server (on same PC running Vista)
    • Windows asked me whether to block/unblock
    • I said 'unblock'
    • Started client, went to LAN Game
    • Found my server
    • Connected
    • Raced
     
  18. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    I had exactly the same experience as Dietmar, my total amount of firewall/router config/turmoil was clicking on "Unblock"
     
  19. Dietmar

    Dietmar
    Premium Member

    Maybe to add one thing (as I just repeated the same under XP, due to my crashing Vista), when I defined my server I unchecked on the first page the Internet Server option.
     
  20. if i start dedicated_server.exe in steam folder , it gives me an error saying it doesnt find steam.dll

    do i need to start this some other way ..??

    i want to practice the wet race ..