1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Race 07 crashes when loading cars in menu (Steam)

Discussion in 'RACE 07 - Official WTCC Game' started by Zpectre, Apr 15, 2013.

  1. I bought the SimBin Mega Bundle yesterday and I'm having lots of problems.

    Race 07 crashes when loading a car at the car selection screen. The crash happens only in the menu, and only when I'm choosing a car. I can cycle through the cars a few times, then the game may crash if I choose another car. It crashes before loading the model in the spinner, and it gives me a minidump.

    It crashes both with and without official addons. No mods are installed.

    I tried everything, redownloaded the game, validated the files (Steam says they're ok), deleted the game's content from the SteamApps folder so that it would unpack again, and the problem persists. I reinstalled Steam and the game once more, and the crash persists. I'm pulling my hair over it, since it seemed like a good deal to get ALL of the SimBin games for the price of a digital copy of a new big budget game...

    Ironically RACE (not RACE 07) works fine. I figured why RACE doesn't crash... It doesn't have the car spinner in the menu... Only from RACE 07 onwards they brought back the spinner from GTR2. But of course I need RACE 07 to make all the addons work.

    DirectX is up to date, GPU drivers are up to date. My specs... Intel Core i7-2600 @ 3.4 GHz, 8GB RAM DDR3, ATI HD 6970.
     
  2. Dennis Phelan

    Dennis Phelan
    more about staying on track. Premium Member

    I'm sure there are others that know more than I do but I'm here. When you reinstall, I would say start with Race then Race 07 followed by the other addons. When starting the game, start using the Race07 Icon or pick it to run from the menu.
     
  3. Race has nothing to do with Race 07, and the order to install the ad-ons doesn't matter with Steam. You only need to start Race 07 the first time.
    What you can do is this, open the User.plr
    C:\Users\Peter\Documents\SimBin\RACE 07\UserData\Peter
    And search for this line and change from 0 to 1, it makes the cars spin normal.
    High Process Priority="1" // Improves FPS on some systems, but may conflict with some background applications
     
  4. Hi, I solved my problem. It was completely unrelated to Steam.

    I use an application called RadeonPro to create GPU profiles for my games. It turns out I had a buggy version of RadeonPro. Updating it to the latest version fixed it.

    Having much fun with the game BTW. :)

    Thanks for the help.
     
    • Like Like x 3