1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Questions about possible texture problems when exporting downloaded SketchUp objects into BTB

Discussion in 'Bob's Track Builder' started by bioLarzen, Sep 18, 2013.

  1. Hi,
    I guess I should make it clear right away that I know little abut Sketchup as I gave up using it years ago, and just started to use again (SketchUp 6.0, i was told that would be the best version, although it's not the latest). Also, since i know little about creating objects and exporting them, I'll probably use bad terminology and stuff.

    So, the scenario: I'm working on a BTB project that could do with some building objects - besides the ones already available in the downloadable XPacks. I thought I'd try converting some freely available, pre-made SketchUp building models, thus saving all the time and work of creating the models myself. Downloaded some such free models. Following a video tutorial (and common sense), I converted the models into .dae so that BTB's XPacker utility can recognize it. With XPacker I could create an XPack of the object that i could open in BTB. Fine.

    Where's the problem? - you might ask. The answer: with the texture files. The XPacker tutorial videos all point it out that the texture files must have dimensions the powers of 2 (2, 4, 8 etc...). The prefab Sketchup models have texture files of different dimensions, of course. When I load the model in XPacker, I get a notification that the texture files are not of proper dimensions - but it still lets me progress and creates the Xpack.

    Question #1: Do i absolutely need to have texture files with dimensions that are powers of 2?

    I would certainly think so - but when I opened the object in BTB, it seemed to have all the textures just fine, although they were still of improper dimensions. In BTB the building seemed as fine as it should - but when I exported the track in rFactor, some of the textures of the object just didn't render: half the building was simply invisible (although it wasn't the case in BTB - all the textures seemed to render fine there). What puzzles me is that the other half looked OK. so, it seems as if rFactor had only problem with certain texture files, rather than all of them.

    Question #2: If i have to resize the texture files, what size do I resize them to?

    For example, I have a 645x320 image. Neither of the sizes are a power of 2. What sizes should I choose?

    Bonus Question: does the image file's type matter?

    Sources often say it's best to use .dds files. But, right now, I only need my objects to be usable and to render properly - at this point I don't really care if the textures don't look the best they could. It's enough for me that they render and in the right size/place. Should i still convert the .jpg files to .dds then?

    I hope these questions make sense... If not, just ask and I'll try to provide answers.

  2. ebrich

    Premium Member

    For me it's, "start as you mean to carry on". Apparently DDS files are the way to go and they need have dimensions of 8 16 32 64 128 256 512 1024 2048 4096. So any mixture of that lot. ie 64 x 4096 is fine.

    Invisible textures from Sketchup usually mean that the mesh in sketchup needs turning round. I think its right click on selected surface to edit. You should see that the "invisible " mesh is grey rather than white.

    If I had an image of 645x320 then I would choose 512 x 256. This does not affect the "image" texture on the mesh as it "fits" to the space.

    One reason that dds files are used is because they are a good compressed image file and certain games, apart from anything else, get upset if you don't use them!

    Not very scientifically put but I hope it helps.
  3. Ebrich has covered everything,

    I just wanted to add extra information on top about using DDS images. The benefit in rFactor is the FPS (frames pe second). DDS files have MIPMAPS, which are smaller resolutions of the original image embedded in them. When you are far away from an object, rFactor will use the smallest MIPMAP image in the file, as its faster to load and less work for your graphics card. as you get closer, it gradually changes up to the highest resolution image to give you the picture quality.

    Also when someone has their graphics settings on low, rFactor will use the smaller resolution images to improve FPS performance.
  4. Ebrich,
    thanks for the reply! Right now I can say i understand what you're saying - which alone is something, knowing me :) But I'll go and check!

    One thing: those textures that seem invisible are only invisible in rFactor. They're both seem fine and visible both in SketchUp and BTB. Does that make any difference?

  5. Hi,
    thanks you too!

  6. Hi,
    sorry for disappearing. Took all the advice I got here, and now I can mostly do what I wanted to do. Some of the models still behave strangely when exported to BTB - but that's a whole different ballgame I guess, not the problem I came here with.

    Thanks both of you once again.