1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Problems with SRW-S1...

Discussion in 'F1 2013 - The Game' started by jibawakee, Jan 10, 2014.

  1. I just purchased the SRW wheel and started to use it with f1 2013. I noticed that in ALL games if you turn left then quickly right(In the event of oversteer or something) the wheel gets stuck(in the game) to the right and locks there. It happens the most on the Montreal circuit. Anyone know a fix for this?
     
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Well if it's for all games, then it's a software driver issue, or a problem with the wheel itself.

    You don't mention your platform, but if this was happening on a PC, then I would be visiting the manufacturer's website, looking for a new driver, or new controller profiling software (if it exists).

    Actually I am really hoping this is on PC, as this wheel is NOT compatible with ANY console, even though it uses a USB port.

    EDIT: Looking at the SteelSeries website, there hasn't been a new driver for this wheel for over 2 years, and Windows 8 isn't listed (though Windows 7 drivers usually work)

    http://steelseries.com/support/downloads#controllers
     
    • Like Like x 2
  3. Sorry about that Windows 7 x64
     
  4. I do have that driver ill try a different usb port
     
  5. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Yup, that's a good idea, always worth a try :)

    EDIT: If I was working for SteelSeries support, I would also say 'please try it on another machine', 'does the problem persist?'
     
  6. Tried it no luck
     
  7. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    See my edit above ....... if you have a laptop, or can get access to a friend's PC.

    The words were stolen from Logitech support, when I RMA'd under warranty a DFGT a couple of years ago :)
     
  8. I tried it on a worse laptop which just gets by playing rfactor and it works fine it just has trouble on my desktop(Dell XPS 8500)
     
  9. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Another option which I would try, is very similar to changing ports.(if you are comfortable with it)

    Go into the device manager, select your USB hubs/ports, and un-install them. You would then have to re-boot your machine. Windows will re-discover the ports via Plug and Play, re-installing a fresh set of USB drivers.

    Sounds drastic, but it isn't really :)

    It just gets awkward if you have a USB mouse, especially if you are unlucky enough to un-install it's port first .....

    So if you actually KNOW which USB port (in the device manager) that the wheel is connected to, then you would just un-install that one. It's not always easy to find out if you have lots of USB devices though..

    Otherwise you are running out of options ....
     
    Last edited: Jan 10, 2014
  10. I
    Thanks but still didnt work
     
  11. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Oh dear ...... I can't really think of anything else.

    As I would would never advocate Operating System re-installs to suit a game or one device.

    Clutching at straws .... system file checker, to ensure all your system files are good, would not hurt or take long. Will it fix it? ...... I doubt it, but options are scarce.

    Open a CMD window.
    Type sfc /scannow
    Hit Enter/Return

    EDIT: I am officially out of ideas now, waiting for someone to jump in say "Do xxxxx, that will fix it" :)
     
    Last edited: Jan 10, 2014
  12. I know this isn't much help but, i have the had srw-s1 for over an year and i have never had any issues like that with it. I use it for a number of games and the only issue i had was a broken spring in the throttle lever and input lag of the wheel which went away after i moved my os (win 7 x64) to a ssd drive.

    Since the wheel runs on a standard usb driver and the one supplied from the website is only for the rev. led's i would tend to think that it might be the motion controller in the wheel that's broken. As mentioned above you should test it on another computer and if the problem persists i would advice to return it for repair.
     
  13. Try and calibrate the wheel under control panel-game controllers. I've had one for a while and never had the issue.
     
  14. Andy Jackson

    Andy Jackson
    Sponsored by BRUT Premium Member

    I had one of these Steel series a couple of years ago. It worked well until the warranty ran out. Then I started having similar problems. I still have it but it only works properly on the odd occasion. Pity as its a great idea and very practical.