1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with G25

Discussion in 'Sim Racing Hardware' started by Jay Cooper17, Jan 23, 2014.

  1. Can anyone help me with this problem I have with my G25? I was having a practice on rFactor when all of a sudden the wheel cut out and stopped working. I unplugged the USB and re inserted it to which it did it's usual start up procedure, all was fine. I continued on rFactor and a few laps later, the same thing happend. I backed out of rFactor and went to re do what I did before.

    Once I plugged the USB back in, I had a message pop up saying "USB device not recognized". Nothing is seen on the device manager except for a warning symbol next to a USB port stating it's an unknown device. I've tried to re install Logitech profiler and proceed to plug in the wheel when it says that a device can't be found and click retry. But I still get both messages of "A device cannot be found" from the profiler, and "USB device not recognized" in the bottom right hand corner. I've tried everything I know now and it is really beginning to annoy me.
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    Can you try using a different USP port ?
     
  3. I've tried all of the available ports and still get the same result. I've tried everything I can think of but still nothing.
     
  4. Do you have any other devices plugged in that you can remove, or have you added a more powerful graphics card? They might be taking some power which may affect the wheel. Another possibility is a failing Power unit (the G27 unit or the pc PSU).
    It would be good to be able to test the wheel on another pc if possible.
     
  5. No I don't have any other devices except for the keyboard and mouse. I added a more powerful GPU early last year and the wheel has never had an issue with it. I've contacted Logitech about the issue but had no reply from them yet. Not sure how long the waiting process usually is. Unfortunately, I have no other pc's available to test the wheel with so it could be the latter of the suggestions you have made. If it is that, I'll be completely gutted.
     
  6. Hope you get it sorted, I can only suggest a complete uninstall and remove hardware, make sure all trace of the wheel is removed from the system, including all logitech software and drivers. Then check your motherboard/usb drivers, update if possible. Try other usb devices in the ports, make sure they work ok. Then try the reinstall.
    Good luck.
     
  7. I'm trying that now. Although the Logitech folder in Program Files doesn't want to delete for some reason. A stressful day today I think. Thank you for your help. :thumbsup:
     
  8. If you have your old graphics card you could also put that back in, it's a pain, but it might be worth testing to see if it works when less power is being used.
     
  9. I seem to remember having a very similar issue with my G25 years ago. IIRC, I had to uninstall the Logitech software completely, clean the registry and then reinstall and follow the instructions carefully when asking you to plug in the wheel to the USB port.