1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems when I upgraded from Evo to Race On

Discussion in 'RACE 07 - Official WTCC Game' started by traind, Jan 9, 2010.

  1. A few things when I upgraded from Evo to Race On:
    1) My G25 paddle shifters no longer work (I have another thread on this but still haven't found a fix)
    2) The bottom row of my car series is whited out--the series are there but each box to click is all white on the bottom row only.
    3) I seem to be missing my Audi R8 and Koenigsegg from GTR Evo.

    Is there a limit to number of car series that can appear? If so, is there a way to delete the ones you don't want so others can replace them?
  2. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Did you try to reassign your controller keys (pedals, buttons etc)? Do you have an excessive amount of mods installed so the default series dont have an icon?
  3. referring your first issue: I had lost FFB after i upgraded to race on. A reinstallation of the g25 software has helped me. - gl

  4. Thanks for the reply and trying to help. I did try reassigning the keys for the G25. On the car/series page in Race On, The default series from the latest software all have visible icons but the bottom row are just blank boxes. This includes series from GTR evo with added modded cars (1) and the GTR2 series as well. I am not sure if I have 'excessive mods'--most of my mods are tracks. The cars I have mods for are mostly the added GTR2 series and then Porsches and Ferraris for one of the series from Evo..
  5. Thanks for the reply. I am hesitant to do this and potentially mess up all the connections my G25 has to other games as it all seems so sensitive based on the upgrade to Race On. Perhaps I will give this a try if nothing else works. I did check and I am running the latest drivers I could find.