1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Problems instaling logitech gaming software

Discussion in 'Assetto Corsa' started by Mike Sterckx, Jun 17, 2015.

  1. I have a driving force gt steering wheel and just downloaded assetto corsa. So i went and downloaded the latest version of lgs from the logitech website.

    I'm on windows 7 64 bit

    I installed the software. I remember when i used to install the software 3 years ago, it asked me to plug in a device at one point. After plugging in the instal process continued. There was no such thing this time however. It just installed.

    After the program installed i clicked finished (or done). Then i got a popup saying "this software might not have installed correctly" and gave some option. I chose "the program installed correctly".

    But apparently it didn't. There is no icon in the taskbar. There is no icon in the start menu except for setpoint which is for my keyboard.

    There is no install folder to be found in program files x86 or program files. I checked in appdata\local, nothing there either. The program is not listed in the control panel under add/remove programs either. Even a search in the register does not show any indication of it being installed.

    I tried reinstalling. Now it goes from step 2 to step 4 really fast. Step 2 is the licence agreement, step 3 is the install and step 4 is finished install. It keeps saying installed successfully but it's nowhere to be found. Tried 4 times.



    Please help
     
  2. Jempy

    Jempy
    Premium Member

    I read on different web pages that the latest driver to download at the official Logitech forum seems to have a problem when trying to install it on Win 7.

    The 1st advice that other people give is ... downloading this driver from somewhere else.
    Should the official one been prepared for Win 8.1 and making problem for Win 7 ? .... maybe the reason why it doesn't work ?
     
  3. put it into compatability mode see if that installs it ok
     
  4. Nope, didn't work either, same problem. I managed to fix it though. The only driver that worked was one that was on the softpedia website. Thanks for trying to help!