• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Problem with Fanatec CSR Elite Pedals

Discussion in 'Assetto Corsa' started by Bramster, Sep 9, 2015.

  1. Bramster

    Bramster

    Messages:
    6
    Ratings:
    +0
    Hi all,

    I've been trying to install/configure my Elite Pedals, but it just doesn't work. CSW V2 works fine, but it's like the pedals don't get recognized when I try to configure them. So as a result, obviously, I can't give any input when I try to do a race... Everything works well in my other sims. Anyone else had this?
     
  2. Joao Alves

    Joao Alves
    Premium

    Messages:
    933
    Ratings:
    +423
    Do you have them plugged straight into the computer, or a usb hub? Mine had some spotty issues when I had them connected via a hub.

    Maybe @Chris Stacey can give some insight?
     
  3. Bramster

    Bramster

    Messages:
    6
    Ratings:
    +0
    I have them plugged in in my CSW.
     
  4. Chris

    Chris
    Administrator Staff Premium

    Messages:
    9,430
    Ratings:
    +5,811
    Hmm, I didn't get a notification from this...

    @Bramster if you go into "control panel > Hardware and Sound", what name appears for your pedals? Or do they appear at all? They should register as "Clubsport Pedals"
     
  5. Bramster

    Bramster

    Messages:
    6
    Ratings:
    +0
    I'll check tonight!
     
  6. Bramster

    Bramster

    Messages:
    6
    Ratings:
    +0
    Couldn't check until now. The wheel appears, but no sign of "Clubsport Pedals"...
     
  7. Giando Fraschini

    Giando Fraschini

    Messages:
    13
    Ratings:
    +5
    Hi... have the CSR Elite pedals too...
    Sorry to ask, but are you 100% sure that the cable is connected to the pedals base?

    The plug in the base is quite loosy, i've experienced it sometimes and i was convinced it was all in and then after i realized i needed to plug the cable well and deep.

    Let's check it out!
     
  8. Bramster

    Bramster

    Messages:
    6
    Ratings:
    +0
    The pedals work in pCars, so pretty sure :)

    But thanks for contributing, and trying to help me find a solution!
     
  9. Giando Fraschini

    Giando Fraschini

    Messages:
    13
    Ratings:
    +5
    Ooooh so the pedals do not work just in Assetto Corsa?

    That's weird... could you maybe upload a screenshot of your 'control' options panels?
     
  10. Brandon Wright

    Brandon Wright
    I may not be fast, but I'm wide! Premium

    Messages:
    3,884
    Ratings:
    +1,599
    Have you tried plugging them directly into your PC? That's how I have mine setup and they work in all sims and show up as a separate device in the controller panel.
     
    • Agree Agree x 1