1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Problem with audio in F1 2010 - just started happening

Discussion in 'F1 2010 - The Game' started by F1 2011 Rocks!, Jan 19, 2011.

  1. And coincidentally (or not), the issue has only been happening since I got my wheel. It seems to be permanently stuck in software mode, which won't do for several reasons; some of which are the speakers crackle, the FPS isn't as good and most importantly, the game keeps hanging on the loading screen.

    I tried 'verify integrity of game cache' in Steam, and that worked - it returned Rapture as the default. It worked, until I quit the game; when I tried to play again, it had once again returned to software mode! Here is the relevant part of my hardware settings info file:

    <unsupported type="hardware" index="0" voices="0" />
    <mixing type="software" index="1" voices="192" />
    <unsupported type="rapture3D" index="5" voices="0" />
    </audio_card>

    So this one clearly has Rapture as unsupported for some reason.


    And here is the part of the copy I made after the verify game cache process:

    <mixing type="hardware" index="0" voices="127" />
    <mixing type="software" index="1" voices="192" />
    <mixing type="rapture3D" index="5" voices="192" />
    </audio_card>

    But even if I delete the other file and run with that one, once in game, all I get is software mode - same thing happens if I delete both of the files. At first I thought this might be some sort of conflict between the wheel and soundcard's drivers, but when I tried DiRT 2 today, it was fine - it ran in Rapture by default and there were no problems. This is a hugely annoying problem and is rendering F1 2010 unplayable right now. Would reinstalling it completely help? It's a drastic step, but if that's what I have to do, then that's what I'll do.

    Incidentally, what's best: hardware or Rapture?

    Typical, I take a long break from F1 2010 and then when my wheel arrives, this has to start happening! :mad:

    Thanks in advance for any help.
     
  2. Set your hardware config back to rapture then make the file read only and it will not be able to change it back, I hope this help's
     
  3. I think I already tried setting it to read only - and in game, the only option available is software - Rapture isn't even greyed out, it simply isn't there at all. It's worth another go though; thanks for your reply. :)
     
  4. Nope, it didn't work. I checked the file and Rapture3D is still listed as supported, but when I go into the game, all that's there is software mode. Only doing the verify game cache process works, but when you exit the game and restart, it's back to being stuck in software mode. This is infuriating. As I said, it's not happening with DiRT 2 - that's running no problem in Rapture3D, so I don't think it's anything to do with driver conflicts.

    I even tried reinstalling the game, that didn't work either!
     
  5. This is especially annoying - when I stayed in the game to play with Rapture3D before it got reset back to software, I was carving huge chunks out of my gamepad lap times. Still - if I have to run the verify cache process every single time I want to play, that renders the game close to unplayable for me - for one thing, every time you do that, you have to reinstall every flipping mod you've ever installed. Looks like it's DiRT 2 time until I can get this annoyance sorted out. It can't be anything to do with the drivers because it runs in Rapture3D after the verify cache/update process. :confused:
     
  6. Have you tried un-installing the F1 Rapture 3d driver's and install the old dirt 2 one's over them see if that help's or in the start menu Rabutre installs a configuration utility, I took rapture off completely as I have no soundcard and with rapture in it sound's crap even on software setting's.