• Home of the RD Le Mans Series by Vesaro
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

port help

Discussion in 'rFactor' started by Dean Tew, Jan 29, 2009.

Thread Status:
Not open for further replies.
  1. hi every bod. can anyone help me with the ports i need to open to host a room please.
  2. ive opened ports 34000 to 35000 and still no joy. ive even tried tyka client.
  3. Are you hosting a dedicated server?

    Ports to be forwarded from your router are (TCP/UDP) 34297, 34397, 34447 - and (TCP) 6565. You won't need to open up any more than this, and in fact without trying to sound too paranoid, decreases the effectiveness of your security. Best to only open what you need.
  4. cheers mate it might be the tcp 6565 thats the prob will give it a go
  5. just tried it, no joy.. its driving me mad.. why do they make it so difficult!
  6. also - have you applied the multiplayer.ini hack thing to make sure you can see all the servers in the lobby? (or a lot more of them anyways).... your server might be there and you're just missing it because of that....
  7. It's only difficult when it doesn't work! lol

    Have you got other things forwarded OK? I mean are you sure it's not a network config thing, rather than a port forwarding thing? Static IPs correctly setup etc?

    It might be worth double checking what Andrew mentioned too. The thread is sticky, at the top of the page, link here too: http://forum.racedepartment.com/rfactor/9272-cant-find-rd-servers-rfactor.html
  8. cheers chaps... to be honest its the first time ive fiddled with ports. i didnt know about a static ip i will look into that.. i can get my room onto matchmaker but when someone tries to join they get timed out if that means anything to you..
  9. ok ive got a static ip on the pc, do i have to change the router to the same ip?
    your help is much appreciated.
  10. Nope - it just makes things easier with a router if you PC is on a static IP. The router will have a different IP and will be static anyway. Now you need to forward your ports from the router to the same IP that the PC is set to and all should work fine..

    You might also want to go here if you haven't set ports up before for your router: http://portforward.com/english/routers/port_forwarding/routerindex.htm

    Find your router in the list, then find rFactor and follow the guide. Hope this helps.
  11. 34297

  12. cheers for all your help lads but i bloody give up, i dont think all the tea in china could help me... ive even turned the firewall off just to test it.. my router gets its ip dynamicly from the isp is that right?... i tried bashing it too lol
  13. Dean,

    Yeah you're right, but networks are never that easy :laugh2:

    Try to remember your router essentially has 2 IPs. One is the public IP, which is visible to the internet, and the way people can connect to you (and will be the one that shows up on websites such as myipaddress.com.) Depending on your ISP that might be static or dynamic (changing every now and again.) The other is it's private IP - which is only visible to your network (your PC and anything else connected to the router.) You can tell the private IP because it normally starts 192.168.1.x or 192.168.0.x - there are other variations, but it's normally one of the examples I gave. If you really want to know the router's private IP address, run an ipconfig /all from a command prompt and the gateway address will be your router's IP - look for the group of numbers with a description the same as your network card..

    I divulge - actually what I wanted to say is if you want a little help, let me know, I do this (dull to most) stuff for a living. Send me a PM, or if you use Google Chat I'm reachable most of the time at skymonkey.org@googlemail.com - that's the same for anyone else here if they want to add me as a contact.:)
  14. thanks for the info guys was having bito probs with this stuff myself but got it going now
  15. No problems - I had a look at Dean's config last night and it's all working now as well. :good:
  16. cheers paul your a legend, im now hosting whoop whoop
  17. actually i thought i would put a little something for people that may read this in the future..
    do NOT take any notice of the ingame hosting test in the settings... it dont work...
    just follow the steps above and make sure show in matchmaker is set to yes..
    happy racing people
  18. I was just gonna comment on the router issue .....always difficult when you talk about diff routers cause i couldn't get my linksys router to work so i bought me a Netgear and it worked like a bomb.
Thread Status:
Not open for further replies.