1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Performance in multiplayer

Discussion in 'Assetto Corsa' started by Cedric Germain, May 12, 2014.

  1. Hi all,

    I noticed a performence hit by playing in MP.
    With 20 or + cars on a grid, I have a lot of small stutters. In the pits, it's awfull.
    I'm playing with a 120Hz Monitor and have 60 FPS +/- (50FPS at the start) and 70 or more during the race.

    In Turns, the stutters are bigger (big issue in Magione)

    When I'm alone on track (test) It's smooth (or quite smooth, I still have stutters when I turn on Magione)

    my config:
    i7-3770K, 4x3.50GHz / GTX 780 3GB
    IIYAMA 27",120Hz, 1920*1080
    Volant G27 / Win7-64 bits

    Do you experience such issues?

    Thanks for your feedback.
     
  2. Not sure about the fps, but if u have a 120 hz screen and u don't reach atleast 120 fps, its really awfull to use ( friends told me).

    U shouldnt really have any fps problem with that card tho
     
  3. Thanks Sander for your reply

    "Not sure about the fps, but if u have a 120 hz screen and u don't reach atleast 120 fps, its really awfull to use ( friends told me)."

    --> I was wondering about this point indeed.

    I will try to put my screen at 60Hz and do a test tonight
     
  4. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    I'm runnning 3 x 120 htz screens in 3D and it looks amazing and runs super smooth. 60-120fps
    i5 2500k and a titan card. :)
    but i have not maxed out the settings.
     
  5. @Rupe Wilson: tell me your secret :)

    I found this on a old topic saying:

    120 hz monitor users, change refresh via config file:
    "Mine was set to 60 by default...
    The directory as follows: Documents/Assetto Corsa/cfg/video. Change refresh to 120
    Input lag should be significantly better.
    Report back findings!


    I will try it as well
     
  6. Just wanted to say that your FPS should be way better than that.
    I still have the error showing high cpu occupancy on my main rig but at least the game does not "pause" like on my older racing rig.
     
  7. Rupe, which screens are you using? I'm currently using a single Dell U3011 30" monitor but I'm considering three BenQ 2720Z 27's.
     
  8. Maybe overclock the cpu mate wil also make a difference.
     
  9. I noticed it too. stutter cars. Lag
     
  10. any news Cedric?
     
  11. So... I tried yesterday different settings:

    - to put 120Hz in the Assetto corsa/cfg/video
    - to launch AC via Logitech Profiler
    - to put my monitor on 60Hz with refresh rate 60Hz and 59Hz in game
    - to put FPS cap at 100 FPS at 60FPS
    - to active/desactive/adaptive Vsynch in Nvidia inspector/Nvidia control panel/in game
    - to make ALT+ENTER during racing


    and I have micro stutters (when I am alone on the track stutters are in fact very hard to see) and only on the environment (on certain objects like buildings, marshalls on the track)

    With 15/20 cars on multiplayer, I have 70FPS at start and in pits (when all cars are there) and 100-140 FPS during race and I notice those small stutters

    It's minimal in race, but I'm stuttters allergic :D

    The better results for me are: no Vsynch at all and 120Hz refresh rate.

    I think it's just because we are in beta, I'm quite sure they (Kunos and Nvidia) will improve it later.
     
  12. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    Sorry for delay in posting.

    im sorry to say i have no secret ive not really tweaked any setting Cedric. i mainly leave it all as stock settings. and because it runs smooth i do not touch it. I dare not tweak anything in case it goes wrong.

    The Sceens i use Bikout are.
    BenQ XL2420TX 24 inch Widescreen LED Monitor (1920x1080, 2ms, VGA, DVI, 2x HDMI, DP, NVIDIA 3D Vision 2 Ready, Black eQualizer, 120Hz Refresh Rate)
     
  13. I have a similar problem. my framerate is okay and my ping too. but the opponents are pretty stuttering especially the high ping opponents. i think it has nothing to do with screens, settings or pc specs. do you understand? Alpha stage.

     
  14. i have a I5 2500K at 3.8Ghz , Radeon HD 7970 3GB , with triple screens at 60Hz , Vsync is on, i run max on everything offline and its smooth, but online i lag so bad :( , have to reduce my settings to minimuim or low :(
     
  15. Dave Begley

    Dave Begley
    Premium Member

    @Scott Webber have you made sure no background processes are causing your probs.
     
  16. yep never have anything running apart from steam & ts :)
     
  17. It's interesting to see the various performance issues on different yet some powerful hardware.

    In SP I get lots of CPU utilization prompts at the top of the screen. Yet last night in the RD Club race I had non with 23 cars on the grid.

    Sound crackles when there's a lot going on though.

    @Scott Webber have you tried switching vsync off?
     
  18. yep done that, i get very bad tears in graphics, i have to keep it on for all my games :( , i hate the graphics card, really hate amd tbh :(
     
    • Agree Agree x 1
  19. :( that's not good news mate. Any chance to borrow another card from a mate to test?
     
  20. Andrew Scott

    Andrew Scott
    Premium Member

    @Scott Webber

    Have you tried previous Graphics drivers, sometimes AMD's drivers can have issues with particular hardware combo's. I use to run AMD cards but had so much drama with new drivers failing to run properly I got real pissed off and went back to nVidia, haven't had any drama's since. Currently running a GTX 770 4Gig and it's Awesome.