1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pedals range

Discussion in 'Stock Car Extreme' started by Ali Alami, May 1, 2015.

  1. Hello,

    I'm having some trouble with my G27 Throttle pedal.

    Even when I pressed it to the max, it shows around 85 % pressed in-game

    I know I have to clean the pots sooner because it's a common G27 pedals issue. I saw a tutorial for cleaning the pots (quite complicated and risky)

    in the meantime, is there a way to decrease the pedals range in stock car extreme like we can do in rFactor 2 when we set the max range ?

    I can't find this possibility in the game options like rf2, AC and pcars where I can overcome this issue by decreasing the throttle range to 85 %

    May be something to change in the controller.ini ?

    I need badly any help, because it's impossible to play GSCE with this pedals issue.

    Thanks
     
    Last edited: May 1, 2015
  2. I'm not sure if GSCE has the range slider, but perhaps try limiting it in Profiler-Acceerator-Axis Sensitivity, but its tricky as there's no image though.
     
  3. Martin Vindis

    Martin Vindis
    Premium Member

    Wouldn't a re calibration sort this issue? I tried this and only push the brake 80% when asked for it. When done calibrating i had 100% brake at 80% input.

    In Windows Vista/7:
    1. Go to Control Panel.
    2. Select Devices and Printers
    3. Right click the G27 Racing Wheel
    4. Click Game Controller Settings.
    5. Select Logitech G27 Racing Wheel USB in the list
    6. Press CTRL+SHIFT+ Left click on Properties.
    7. Go to the Settings tab.
    8. Click Calibrate and follow the instructions on the screen.
     
    • Like Like x 2
  4. Thanks Martins and Joel for your suggestions.

    I'm trying Martins Procedure first because I want to limit the range for all games, not a specific one.

    I followed the steps until the first wizard screen asking to keep the wheel centered and then press a button of the controller.

    The wheel was centered but when I press a button, nothing happens. the wizard does not move to the next screen!!

    Any idea please ?
     
  5. Martin Vindis

    Martin Vindis
    Premium Member

    That's weird. Did you try and click the next button with your mouse?
     
  6. Yes, it moves to the next screen, but the whole process is corrupted, there is not progress bars appearing when I press the pedals even when raw data is checked.
     
  7. Not sure if it will work for you, but it's worth a try : choose a different controller preset in the game and rebind the axis.
    I had a similar issue with throttle pedal dead zone (only the last 10% of the travel worked) and choosing preset "paddle" solved the issue for me.
     
  8. Jan, can you explain a little more please ? because what I would like to achieve is that the game shows 100 % of throttle when I'm actually only pressing the throttle pedal at 80 %

    Thanks
     
  9. Martin Vindis

    Martin Vindis
    Premium Member

    Not sure what to try next. Only thing I can think of is to reinstall the wheel because it seems like the calibration isn't picking up the signal correctly or at all.
     
  10. Sorry, i don't know what else to suggest. Increasing throttle sensitivity may help a bit.
     
  11. I managed to get the calibration process to work by going to the test Tab and then depress pedals and went back to settings and click on the calibration button.

    But I want to ask you some more questions please:

    when I press the pedals, the value is decreasing, so I have to pick 20 % or 80 % ?

    Do I have to press a button on the controller to validate the wheel range or just click on next ?

    Please bear with me :)
     
  12. Martin Vindis

    Martin Vindis
    Premium Member

    I noticed this as well, seem like the pedals works in reverse. When you don't touch the pedal it sends a signal of 255 (100%), when it's fully pressed the signal is 0 (0%).

    You should push the pedal all the way down, then release it and finally press a button. Keep following the calibration guide and you should be fine.

    If you still have issues after this, do the calibration again and only push the brake pedal until the meter says 20% and then release it and continue.
     
    • Love Love x 1
  13. Hello Martin,

    I have the issue with the throttle pedal.

    Please take a look at this screen capture where I did what I could but still can't manage to have 100 % Throttle at 80 % input as you can see in the end of this video.



    Can you see what I did wrong ?
    Please notice that I press a button on the controller to go next

    Cheers
     
  14. Martin Vindis

    Martin Vindis
    Premium Member

    What you did wrong was that you pushed the pedal to 0% first, then released it and pushed it to 20%. You don't want to go below 20% at any given point because the calibration will get that reading and use it as a max input point.

    Here is a video of me doing it.


    If 20% doesn't work for you, try 25% or 30%
     
    • Winner Winner x 1
  15. Finally it has worked thanks to your very clear video.

    Thank you very much Martin. I can now race normally until I clean the pots properly

    Cheers
     
    • Like Like x 1