1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Paddle shifters wont work?

Discussion in 'RACE 07 - Official WTCC Game' started by Roger Snead, Jun 24, 2012.

  1. Greetings to all,
    I just set up Race 07 on W7 64 bit using Fanatec Elite and CSP's. I can't seem to get the paddle shifters to work.
    I am using a car labeled semi'automatic, have auto shift OFF, and have succesfully mapped everything. The game even recognizes wheel. Well it says Fanatec CSR. Close enough. I have the H gate shifter in Neutral. It works fine, but not the paddles. What am I doing wrong? When trying to use paddles it stays in second gear when I shift up or down. Thank you.
  2. Yves Larose

    Yves Larose
    Premium Member

    i would say look for 2 things, the first one make sure that the paddles are the assigned key for shift up and shift down and the second thing is an option that it might be on that allow the H shifter to work but that needs to be turned off when using any sequencial system, the option is in the advance setting and its called " Hold button for gear "
  3. Surely you dont mean I use the keyboard for shifting. I mapped the paddles to the shift up/down. I selet shift up and the pop up box says assign or ESC. I assign by pressing the up shift paddle (rt) and same for shift down, I highlight shift down in menu and then click on the left paddle.
    I will turn the Hold button to OFF and see. Thanks
  4. Yves Larose

    Yves Larose
    Premium Member

    nope i didin,t mean that you are using the keyboard, the Hold button gear option is for when you use an H shifter.
  5. Still cant figure it out. Stays in Second. Auto and 6 speed work. I even unmapped every gear in the H shifter.
  6. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    When the car is stuck in second gear make sure the gated shifter is in neutral or even better remove the assigned keys you use with your h shifter.

    Have you tried to disconnect the H shifter completely and see if then the paddles work?
  7. I will try disconnecting and get back. Thanks. Really like your F12011 car setups BTW;)
  8. UPDATE....I disconnected the H shifter, but still no paddle operation.
    Finally figured it out after about 30 min. :O_o:
    Options>>Controller>>Advanced>>"Use Wheel to Shift Up/Down" = OFF
    I had it set to "ON" (seemed logical)
    I guess this refers to when using the mouse as a controller. I assume one uses the mouse wheel to shift. Not exactly sure how that works. I will quit all sim racing before it comes to that. :p

    BTW, Is this sim tough to get used to? Seems harder than rfactor. I still have a lot to learn. I improved my lap times a lot once I got FFB sorted....big difference.
    It is harder to see everything compared to rFactor. Everything seems more distance, smaller I guess is what I mean.
    The AI acts like none other:O_o: They are hitting me from the back, sides,, you name it. AI strength only at 85, being a newbie.

    I could not get the CUSTOM setting to work for all kinds of things. It was shaded, along with a bunch of settings. All I could do was select NOVICE,SEMI-PRO, PRO, EXPERT, or whatever it was. Then at the end was CUSTOM which was shaded out with a ton of options. I don't get it. That's what CUSTOM is all about, being able to run different options than what each difficulty defaults to.:unsure: Any help would be greatly appreciated.
  9. Pleased to see you got the gear change issue sorted out.

    I don't think its harder to get used than rFactor - just a bit different and so needs time to get used to it - hang in there it'll come.

    Ugggg AI, is horrible, you'll find they vary from track to track too, much better to get online against real humans, either in publics, or in the RD racing club - yes theres lots of rules, be courteous of faster drivers and you'll be fine. If you must use AI then set them higher, its better to have something to chase than it is to have crazy AI bumping you to get past and then braking at stupid points on the track like they do.

    The CUSTOM settings are greyed out until you change something in the others so if you select PRO then change one of the options you will find it then becomes CUSTOM because its no longer on PRO settings - its logical really, but I can totally understand how it could confuse someone new.
  11. Yes, thats typical way these sims work. I tried selecting Novice, which defaults to Auto Tran, I changed it to manual, and expected Custom to light up and be ticked. But not so, I move away from the page and come back to check, and it's back on Auto again w/ Novice ticked. Over and over.
    I will try it in reverse...tick PRO and uncheck some things and see if it goes to custom.
  12. Ok, I got it. I needed to first select Custom Championship, a page before, to get Custom settings available. Looking good now.
    BTW, The main reason I bought this sim is because the infamous recent software update on the 360 wiped out all my FFB on Dirt 3 and RacePro. Race 07 nicely takes the place of my now useless RacePro. Thanks M$ :mad: The following update on the 20th restored Dirt 3...thank goodness, but not Race Pro. I can't even buy a new Race Pro to solve the issue. My 360 Slim will never be able to run Race Pro of any copy, unless they come up with a fix it update. Did anyone else have this happen?

    Also, now, who knows what games and sims will work when you buy them from now on. :cautious: This should be on another forum I guess....sorry.

    Thanks for everyones help. :)