• "Bite off more than you can chew and then chew like hell." - Peter Brock
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nvidia Video Cards + Drivers

Discussion in 'Off Topic' started by Marcel Hulsbergen, Jun 23, 2008.

  1. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    Nvidia has released the Official Forceware 175.19 drivers for Windows XP and Vista. These drivers are for all GeForce 6, 7, 8 and 9 series graphics cards, and contain improved performance and load times for the GeForce 8 and 9 series in some DX9 and OpenGL games due to an improved shader optimizer. They also contain a range of fixes.
     
  2. Simon Trendell

    Simon Trendell

    Messages:
    5,023
    Ratings:
    +7
    Strange problem first time I loaded race but hasn't re-occurred since...#

    Never had a problem with the old drivers so apart from above I've noticed no difference
     
  3. Gary Lennon

    Gary Lennon

    Messages:
    3,273
    Ratings:
    +202
    Just dloaded this and getting ready to install,will it become a problem with my RivaTuner/D3DOverrider util?,probably require a fresh install of that as well? :confused: :o.

    Thank You
     
  4. Simon Trendell

    Simon Trendell

    Messages:
    5,023
    Ratings:
    +7
    The temp monitor works fine for me with this version, not tried anything else.
     
  5. Gary Lennon

    Gary Lennon

    Messages:
    3,273
    Ratings:
    +202
    Seems there was no effect with the Riva/D3D util at all,new drivers in,now to go see if there are any differences.

    Edit Update: Currently cant get Race07 to start,2 different kinds of horrible crashes so far......
     
  6. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,398
    Ratings:
    +234
  7. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
  8. Gary Lennon

    Gary Lennon

    Messages:
    3,273
    Ratings:
    +202
    Thanks for that heads up WizardMan,ive rolled back to 175.16 and i am happier,that 175.19 thing was bad news!.
     
  9. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    I added a warning to the title, sometimes news can be bad yes :)
     
  10. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
  11. Simon Trendell

    Simon Trendell

    Messages:
    5,023
    Ratings:
    +7
    After my rather annoying video crash in the league yesturday I may be giving this 1.77 version a go.

    Thanks for posting
     
  12. Gary Lennon

    Gary Lennon

    Messages:
    3,273
    Ratings:
    +202
    Im in no rush to muck around with drivers again,keep updating here please on the latest news on those new drivers/fix :thumb:.
     
  13. Jacek Kozlowski

    Jacek Kozlowski

    Ratings:
    +0
    I try those for few minutes but had strange crash and instaled the old one once again-175.16 those work perfeckt for me.Dont know whats is wrong with the new one,first time have that kind of problem with new drivers??
     
  14. Clive Siggs

    Clive Siggs

    Messages:
    716
    Ratings:
    +0
    Well, I updated my driver to the 175.19 and so far I've had no problems to my knowledge.

    Currently running with a 8800gt 512mb @ 1680x1050 resolution. Race'07 is nice and smooth and CoD4 runs like before with a pretty much stable 250fps with my slightly modded config.
     
  15. Jacek Kozlowski

    Jacek Kozlowski

    Ratings:
    +0
    Clive do You see any improvment with race07 fps,do You have more fps with 175.19 than You had with older drivers??I have 8800gts512mb and run also res.of 1600/1000 with antylasting set for 3.Really it would be nice to have more fps but dont know is it worth to try those drivers again since i had crash trying to ran race07-dont know why?
     
  16. Clive Siggs

    Clive Siggs

    Messages:
    716
    Ratings:
    +0
    Good question Jacek, I've never really checked my fps during Race'07. All I can say is that it runs smooth for me with Anti-Aliasing set to 4 and vertical sync turned off. I guess the only way I can check is to run fraps in the background which I don't have installed at the moment but to be honest I hate rolling back drivers if the latest one's are not causing me problems. Still no crash or anything yet.

    Having more fps can help for sure but more important to me is having a game which runs smooth and having stable fps even if it might have been lower. Sometimes benchmarks are not a good guide, due to them being targeted at achieving the highest fps possible but not really testing how stable that fps is.


    In your case I would use what ever works for you - if you are getting crashes then I'd say stick with the older drivers until another release comes along. Afterall, it won't hurt :)
     
  17. Jacek Kozlowski

    Jacek Kozlowski

    Ratings:
    +0
    Thanks for Your reply Clive.I think i stay with 175.16 for now as i dont have any problems with it.
     
  18. Gary Lennon

    Gary Lennon

    Messages:
    3,273
    Ratings:
    +202
    Didnt have much to do,so just found myseld installing our new 177.41 with a modded.inf,off to see if all the great reports on them will apply to me.
     
  19. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    New Nvidia Beta Forceware 177.79

    Nvidia has released a new Beta Forceware 177.79 driver for Windows XP and Vista. These drivers are only for the GeForce 8, 9 and 200 series graphics cards. These drivers add support for the GeForce 9500GT and 9800GT cards, and contain a range of fixes primarily for GeForce 9 and 200 series cards, as well as performance improvements.

    These are Beta's but they perform very well on my system.
     
  20. Attila Domján

    Attila Domján

    Messages:
    9,652
    Ratings:
    +20
    Is it stg you suggest to go for then Marcel? The last beta was a huge performance drop on my system.

    p.s.: also i remember you suggested some nice setting for the Nvidia Control Panel, but since the video card change i lost them, would you be please so kind to repost them what was it? triple buffering setting, AF etc... thanks a lot in advance!