1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Shadows on track surface

Discussion in 'Bob's Track Builder' started by Shawdad, Dec 21, 2011.

  1. Shawdad

    PSN ID: Shawdad

    Hey all. I just recently purchased Bob's Track builder so I am still a bit clueless about this whole track building business. I am currently creating my track surface. I have the texture, bump and spec maps (seemingly) working correctly but I've noticed that when I test it in rFactor, there is no shadow from the car showing on the track. I have parts of my track using the default road texture for comparison and they appear normally but as soon as I drive over my own road texture, the shadow disappears. Any help would be appreciated!
  2. I know there is an option to set whether an Object or SObject "receives" lighting and/or shadows, I assume there must be a similar setting for roads and/or textures. Let me have a look...
  3. OK, I've had a look in BTB, is the section of road where your road is used (where there were no shadows) on a different track to the default texture (where the shadows worked)? If so, maybe try this:

    • Click on the icon marked "Edit/Switch Active Track" (6th from the right, the icon is white with black marks that look like train tracks formed in a "T" shape)
    • Select your track that has the section of your texture on it (The default name is "Track <<Date Created>> <<Time Created>>)
    • Make sure that the checkbox to the left of the words "Shadows receiver" (near the bottom of the window) is ticked. It is probably also a good idea to tick the checkbox to the left of "Receive lighting" as well.
    • Click on the "Close" button and try exporting your track again :)
  4. By the way, are you using v0.8.0.3 or v0.8.9.1 BETA? The Instructions I gave in my previous post were taken from the BETA, though I am pretty sure that nothing extremely significant has changed that affects this...
  5. Shawdad

    PSN ID: Shawdad

    Thanks for the reply! I am using v0.8.0.3

    That was one of the first things I checked. It seems that option is ticked by default. So I unchecked and rechecked the box and tried that...to no avail:( I have, however, seemed to have found an alternate method. I made a copy of the default track texture and replaced the diffuse with my own and the shadows work! This leads me to believe it has something to do with these settings in the materials editor within BTB. I'll keep messing with the settings. Thanks again for your help! Ive been browsing these forums and it looks like you have a great community here. Glad to be a part of it!
  6. Have you made sure that the material's 'Emissive' colour is pure black? Anything above 0,0,0 will turn a material into an illuminated surface (even 0,0,1), which may prevent shadows being drawn.
    • Like Like x 1
  7. Shawdad

    PSN ID: Shawdad

    That did the trick. Thanks R Soul. Not even sure how Emissive got changed...must have mixed it up with specular. My fat finger syndrome plaguing me again...

    Problem Solved!;)