1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No KERS for lower teams

Discussion in 'F1 2011 - The Game' started by TheRealF1fanatic, Sep 21, 2011.

  1. I'm only on the first race weekend with the Lotus and my blasted KERS doesn't seem to be active. Now that's realistic, lol. Judicious throttle management is required when coming out of a turn with the DRS turned on.
     
  2. Chris Jenkins

    Chris Jenkins
    Driving til the wheels fall off

    Lotus, Virgin and HRT do not have KERs, as they are not running the system in real life this season.
     
  3. that's brilliant... I was hoping they wouldn't have kers in the game to make it more realistic. I was expecting Codemasters to give them kers to make it more fair.
     
  4. Well that makes sense. I'll stop yelling at my race engineer then. I still need her to fix dinner tonite. :tongue:
     
  5. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    The poor woman lol :)
     
  6. As you progress through your season and career you be able to gain KERS for your team as an upgrade! But only if you are driving well and keeping up with the objectives!
     
  7. Chris Jenkins

    Chris Jenkins
    Driving til the wheels fall off

    Is this confirmed? As Steven Hood was quoted as saying that the 3 new teams will not have KERS available in the game.
     
  8. I asked this question in the Question and Answers thread and he said that from what he has heard and read it should happen! I would of thought it would because otherwise there is no point staying with these teams as they are never going to be able to compete with the mid table teams no matter how well you drive!
     
  9. they dont have KERS in the game.. they do in multiplayer if all cars are set to equal
     
  10. Do you mean at the start of the game or they will never get KERS?
     
  11. they wont have in at all in SP..
     
  12. YOu started with a LOTUS....i guess thats why.. I went with ForCe India and I have all systems working. Fail in your part maybe?