1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No FFB Please Help

Discussion in 'Richard Burns Rally' started by Jason Murphy, Feb 21, 2014.

  1. Hey guys, i wanted to check out RSRBR 2014 so i loaded up RBR fresh on my pc. I have a SSD and didn't have room there so i loaded on a separate HDD that i have running some programs. I found the patch 1.1 and patch 1.2 and installed them (though it didn't ask for the location im assuming it found the directory?). I still have no ffb, and im frustrated cuz everything should be working at this point.

    I have a Fanatec CSR in PC works with every other sim i try. Can i get some help?
  2. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    What OS are you running? And you should always double-check where the installer wants you to install the game :)

    RBR -> Patch 1.02 -> RSRBR is also the preferred way to go. Just to be 0.24% more safe! :)
  3. Sorry its Win 7 64bit. I know where i installed it its just not the default directory. I did install rsrbr before the patches, im wondering if the patches will take effect if the game isn't in the default directory? Also, im not 100% sure of the patches where i downloaded them. The thread in RaceDepartment with the rsrbr 2013 has the patches linked, but the links are no good.
  4. Warren Dawes

    Warren Dawes
    Premium Member

    Sorry, but my tutorial for installation of RSRBR2013 is out of date now, I haven't yet installed RSRBR2014, so haven't had a chance to update the tutorial. The basic procedure should be the same, but you need to go to RallyeSim to get the downloads:

    I'd highly recommend that you re-install the base RBR, add the Patches, then test your base RBR to make sure the FFB is working. If it doesn't work with the base RBR, there is no point installing RSRBR2014.
    Try this first and let us know how it goes.

    I have read of others having FFB problems with the latest Fanatec wheels, so it may be worthwhile checking out the RallyeSim Forums or Fanatec support if it won't work with the base RBR.
  5. Ya, ive downloaded all the rsrbr stuff and it seems to be working. I guess i'll uninstall it all and try the base game first. I'll let you know how it goes.
  6. Is it ok that i install the game in a location other than default? Will the patches work?
  7. Michael Nelson

    Michael Nelson
    Premium Member

    it's actually recommended to install it in a different folder to default. For example, mine is installed in D:/RBR

    To the best of my knowledge RSRBR will install the patches. But I agree with Warren, install the base game, and then the patches and then test it. At least this way you'll know if the issue is with the base game or the mod.
    • Agree Agree x 1
  8. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    I also thought RSRBR did that, but I've never had feedback without first applying the patch. I only got force ;P
  9. Well i uninstalled and reinstalled three times. Once to the same drive, once to my main drive and once back to the my second drive a D:\RBR instead of default SCI Game\Richard Burns Rally.

    Applied both patches each time started game made MULLIGATAWNY profile, set up steering wheel (which it always sees), tested force feedback in game and get nothing any of the times. There must be a disconnect with the Fanatec CSR and RBR. I guess I may not be enjoying this sim again after all :(. Ive done some googling about richard burns rally fanatec force feedback but im not getting much.

    Any other thoughts?
  10. Warren Dawes

    Warren Dawes
    Premium Member

    I'm sure I read something somewhere about new Fanatec wheels having problems with RBR, but I also thought I may have read someone getting it to work. Might have been related to firmware or drivers, so possibly at the Fanatec support / blog website. I'll do some searching over the next few days and see what I can find. In the meantime, search RallyeSim, No Grip, or any other websites that covers RBR.
    Sorry I can't help more, I don't have that wheel (mines G27) but I did have a Fanatec GT3 ver 2 which worked fine with RBR.

    EDIT: Just to be sure, I assume you have setup your FFB in the Controls Option? You need to do this for every profile you make, including Mulligatawny.
    Under Options / Controls / Forcefeedback: FFB on, Strength to almost maximum, Direction normal (maybe try Reverse for your wheel???), and did the FFB test (wheel turns left then right by itself) ?
    Last edited: Feb 21, 2014
  11. Yes, each time i completed the install i launch the game after patching and go straight into options/controllers. After i set my wheel axis i then check the FFB settings. On, max strength, normal and inverse, center on or off. When i complete the test i get nothing.

    The only thing i saw was that someone said they put their Fanatec into PS3 mode and then i guess downloaded the logitech profiler and it worked with that. I haven't tried that as i figured that would make it more trouble than its worth.

    Sure appreciate the help. From other forum posts ive been reading your name has come up as the guru of RBR, so i appreciate your help! Don't waste too much time thought ;)
  12. Michael Nelson

    Michael Nelson
    Premium Member

    I was just about to suggest this :p

    Just reading through your post now though, I think you haven't tried installing RSRBR 2014 yet? We had someone else a few months ago (Wow, a year ago... I remember that thread like it was only recent) with Fanatec force feedback issues which resolved when he installed RSRBR. I might add, after trying a lot of other things. :p
  13. I have installed RSRBR. The first time i installed it all i just followed their instructions (which say nothing about applying patches before installing RSRBR). Its been the same no matter how i installed it.

    I'll probably register and throw a post up on rallyesim.com just for kicks but i don't expect much. Its sad, i was kinda excited about trying some rallying again, especially after downloading joux plane for Assetto Corsa.

    Thanks for the help, maybe we'll find a magic solution, but im uninstalling my fanatec drivers to put it in PS3 mode, and im not downgrading my firmware, so if those are the solutions i'll just move along. :)
  14. When i get home today i will try one more time to disconnect the wheel and do the regedit delete of VID_ again. Then i'll reconnect the wheel in a different USB port (which i didn't do the last time) and see if that fixes it.
  15. Dont give up, best rally game ever, assetto is my fav tar game (cos it almost feels as good as RBR) but it does not quite give the same performace as RBR. Really it is definately worth the fight...
  16. Warren Dawes

    Warren Dawes
    Premium Member

    The RallyeSim guys are usually very helpful, and they know RBR better than anyone. Don't be put off by the French language, they have a button on the site that includes English (good for searching the Forum), but just post in English, and they will reply in English (unless you are proficient in French of course ;)) .
  17. Hey guys, i got it working! Come to find out i had older version of the driver. So, i updated to the latest and whalaa ive got FFB! thanks for the help, and sorry it was something so dumb, i really didn't expect it to be that....
  18. Warren Dawes

    Warren Dawes
    Premium Member

    Glad to hear you are up and running, you won't be disappointed. :thumbsup:

    To help us with any further questions along these lines, can you give us more details on how you solved it
    ie. Which driver version was the problem, and which one fixed it?
  19. Somehow i had the 140 beta version. I uninstalled the Fanatec driver v140 and then installed the driver v177. This solved the issue.
    • Beer Beer x 1