• Home of the RD Le Mans Series by Vesaro
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New GTX980 - now GSCE graphics looks terrible

Discussion in 'Stock Car Extreme' started by Rob Fitness, Dec 29, 2014.

  1. Rob Fitness

    Rob Fitness

    i just bought a GTX980 and 3x benq 144hz 24" monitors (upgraded from a GTX590) and now the colors in GSCE are all horrid... its as if the gamma and brightness are cranked up and its using 16bit, like the load screens and menus look as it they don't have enough color depth and are looking grainy and pale.

    iRacing looks fine, desktop looks fine, GTR 2 Fine.... just GSCE is terrible.

    I did a clean install and patched up to 1.21 and ran sync. still no good.

    running the 344.80 drivers

    and just to add...the performance boost i was hoping to get over the 590 in iRacing and GSCE looks to be sporadic & minimal at best too :(

    feeling like i wasted big $$$ for little gains

    any ideas on the horid colours ???
  2. Lazarou


    Have you changed the settings in the config file to match your beast of a card. Mine look like this for a 2GB card.


    I also use Nvidia inspector and sweetfx to enhance the graphics also, other than that mate I am stumped.
  3. Also, try to reset any adjustments (if any) that you previously may have made in the nVidia Control Panel for GSC?
    If there aren't any, well, besides Paul wrote above, I'm clueless too.

    Anyway, this is a setup I can only dream about. Congrats.
  4. Rob Fitness

    Rob Fitness

    thanks for your replies fellas. i have adjusted those settings and check in NVCP for any colour settings that might be game specific, there is none just image quality like AA etc not colours specific...

    i was about to take a few screenies to show you, but funny (not really) thing is when i open the screenie to crop it the colours look fine ?? so its only "in game" that its getting pale and too bright.

    very weird.

    the only thing i can think is its not using the colour settings I set in the NVCP for contrast / brightness / gamma etc are not being used

    i set each monitor up as best i can via its own menus then once i have set the Nvidia surround custom resolution i fine tune that with NVCP colour settings even further.
  5. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Long shot, but maybe if you used Reiza's sweetfx settings before, you might need to reinstall those or something.
  6. There's just no possible a way a GTX 980 isn't a HUGE upgrade over a 590.
  7. Yeah I just got a 980 as well and I'm having the same issues with the colors on the menus and the sky as well. I'm able to run in 4k now and the game itself looks and runs beautifully. Hope there is a solution to these colors soon.
  8. Not sure if anyone else has had this problem but it seems to have gone away for me. The first thing I tried to do was turn off the Gamma correction from my Nvidia control panel, restarted the game (I am using DSR to run at 4k) and the colors looked fine. I thought "oh that must have been it" but then I went and turned it back on and now everything still looks fine so, I have no idea how but..it works again lol.
  9. Can you tell me where you enable gamma correction? Are you talking about the gamma slider in the "Adjust Desktop Color Settings" section?
  10. No, inside the nvidia control panel.
  11. Msportdan

    @ Simberia @Simberia

    hello synth glad to you got your game working. I have a gtx970 and i can't seem to get the CP to work in GSCE. For instance if i enable supersamling etc, it doenst appear any different in game.

    Does yours work in GSCE?

  12. Hardly makes a visual difference. If you want a big difference then set the regular AA and supersampling AA both from Nvidia Inspector. Set them to the same sample amount (eg. both at either 2x, 4x, or 8x). For the supersampling, select "sparsegrid supersampling". When using sparsegrid supersampling, only combine it with regular AA (AKA multisampling) not other forms like CSAA, MFAA, etc.

    That works 100%, unless your PC has an issue.
  13. if you using hdmi that will be the problem NVidia in there infinite wisdom don't set it to full rgb mode and assume because your using hdmi that your plugging them in to a tv had the same issue and ended up getting displayport a cable.
  14. Am running a 670 2gb and my previous inferior ati 6870 looks much better. Am experiencing huge black graphic tears and maybe its a nvidea problem with this :(
  15. Msportdan

    @ Simberia @Simberia

  16. Last edited: Feb 13, 2015
  17. Once I clicked the pics twice (second time for full size) it really hit me; this is what I love about these older engine based sims. Everything is so sharp and clean, it's not full of pretty-but-fake, artistic and dramatic, looking effects like in so many other games (Project Cars, Assetto Corsa, etc.) like a ton of bloom, blurring, DOF, over dramatic-and-stylized lighting (as if the game takes place in some type of fairyland planet, etc.).

    There are a few exceptions, for eg. DOF, and DOF only while A. watching the game from a TV cam, and B. only when you're watching the game from a TV cam and happen to be going for that "I want to feel like I'm watching on T.V. rather than feeling like I'm actually there at the track myself" look.
    • Agree Agree x 2
  18. Game Stock Car looks good to me ;)
    • Like Like x 1
  19. Lazarou


    Even on a 660Ti I love the look of GSC. Takes a bit of playing with settings.
    • Like Like x 2