1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

New Arca Leverage Client 2.0 Released

Discussion in 'ARCA Sim Racing' started by The Sim Factory, Aug 24, 2009.

  1. The new version 2.0 client has been released and is ready for use. New purchasers will receive this client for initial install. If the game is installed from the previous client, no new game install will be necessary, the new client will detect a previous install and use that. Client and Game updates have now been separated. This update does not change the version of the game you are running. Although, to get any future updates, you will need to have this new one installed.

    New Users: http://www.thesimfactory.com/ASR_L1.zip

    - Download and install


    Existing Users: http://www.thesimfactory.com/ASR_L1.zip

    - Download and install (this installs to a new directory)
    - DO NOT INSTALL over old directory
    - Client will read existing license info, no need to re-register


    Included with this client are links to the 2009 Carset graciously created and provided by Irondog at http://www.arcasimcentral.com. In order to race them online, servers will need to have the low res set loaded onto them. This is easily done by copying it form your build to the same location on the dedicated server you are running.

    NOTES:

    ** Client relies on a fully patched (32/64) Windows XP (sp3) Operating system, or a (32/64) Windows Vista operating system. Both have been tested to ensure functionality. If you have any difficulties, please ensure you have no patches pending whether critical or optional relating to .Net Framework 3.5

    ** A few that had the issue where the client would launch, then disappear, try launching it now. If you still have an issue then please run this small utility. All it does is create a directory which is needed in order for the client to work properly. A permanent fix will be applied to the client Monday. Once you apply this patch, just relaunch your new client.

    http://www.thesimfactory.com/Downloads/LeverageClientFix.zip
     
  2. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Tried it today and its even more beautiful then the previous version. The news and link features are awesome.

    Great example how easy distributing the game can be!
     
  3. Talk about not sitting still. You guys deliver, bigtime!
    tx :)
     
  4. i have a very big problem with this new leverage is not work, after double clip on the file the download start after this stop completly and i have just the icon on my desk.please help me
     
  5. Gareth Hickling

    Gareth Hickling
    Premium Member

  6. I have exactly the same problem.
    Do you use a English version of Windows? (I use a Dutch version and on the official ASR forum a guy using a Swedish Windows version also has the same problem).

    PS: I also seem do have done something complete wrong as my old client don't work anymore.:quiet:
     
  7. Same here,its installed and after double clicking nothing happens.
    My old client still works though.
    I can see it running in taskmanager but no movement even after 30 minutes.
     
  8. Please post your operating system specs for me to look into. Also, right click my computer, select Manage, then go to event viewer. There would be something called LeverageServiceLog, if there is, please right click it and select Save As .csv, and email me the file, with a description of your error. Team[at]thesimfactory.com
     
  9. I use XP pro with all updates.

    Intel dualcore E6850
    4GB Ozc platinium 1333Mhz
    Gigabyte P35 DQ6 mobo
    2x 500GB Samsung spinpoint HD
    2x Geforce 260 GTX 896MB Graphics card.

    No log files found ,i had no error installing the client it just does nothing after installation.
     
  10. Check in control panel, then admin tools then Services, see if you have a service called Leverage, if so, please see if it is running, and if it isn't try right clicking and start it.
     
  11. Done that and resulting in an error 1053 service cant be started because Leverage client wont aswer.
    Translated a little bit cuz its in dutch :)
     
  12. Patrick, right click the LeverageService in Services, and then go to the Logon Tab, can you try putting in a check mark where it says to allow it to interact with desktop and then try it?
     
  13. Did that and still same result. wont appear in systemtray or startup.
    I hear my HD do something for 3 seconds then it stops.
    The Leverageclient is in the proceslist and seems to block all other programs i try to run after i start it .
    It just wont go on with what it should do .......make me happy :)
     
  14. Also, go to Run, type Regedit, and then look for this key, should be set to DWord=1

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727\1043
    Install (DWORD value = 1)
     
  15. Bjorn de Haas

    Bjorn de Haas
    Premium Member

    when i click on the leverage nothing happens ... i have sp3 and i also have netframework 3.5
     
  16. There is no 1043 in the key , I only have 1033. So this is my key :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727\1033

    Install (1) DWord
    MSI (1) DWord
    SP (2) DWord
     
  17. Bjorn de Haas

    Bjorn de Haas
    Premium Member

    its strange its not working.. the other leverage was fine in my point of view
     
  18. hmmm, you guys are giving me fits ... ;)

    Bjorn, please follow the instructions I posted a few back about extracting log files if available and email them to me, with a description of OS specs, and what version of XP you are running (Dutch, German, English, etc ..)
     
  19. Bjorn de Haas

    Bjorn de Haas
    Premium Member

    im having windows xp sp3 full updated.

    how can i let you show what system i have i have to typ something in run menu??