• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

NEW + 9.12 Hotfix!!! Final ATI Catalyst™ 9.12 Suite for Windows

Discussion in 'Off Topic' started by Marcel Hulsbergen, Dec 17, 2009.

  1. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    Ati released the final 9.12 drivers.

    http://support.amd.com/us/gpudownload/Pages/index.aspx

    For release notes check the Ati website.

    ATI has released a Catalyst 9.12 Hotfix graphics driver.

    This hotfix is essentially a beta which is newer than the recent Official 9.12 Catalysts.

    Specifically it resolves the mouse being enlarged under Windows 7, improves the performance of OpenGL games, provides support for CrossFireX on Eyefinity setups, OpenCL and DisplayPort Audio support, and has several other fixes.
     
  2. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    I notice a big performance increase in Vantage, arround 1000 points more. So + 8% for me.

    These drivers are highly recommended for Dirt2, as there is a fix included.
     
  3. Lee Downham

    Lee Downham

    Messages:
    1,970
    Ratings:
    +1
    I was on the Dirt2 betas but will bash these in now and test with this ere 5770.
     
  4. Rob Shillito

    Rob Shillito

    Messages:
    1,723
    Ratings:
    +30
    with any luck these plus my new psu will fix my 5770 problem
     
  5. Piotrek Blaszczak

    Piotrek Blaszczak
    Premium

    Messages:
    976
    Ratings:
    +585
    Is he fix the Anty Aliasing problem??I have a 4850
    When i install the 9.11 drivers i have a problem with AA playnig Sim Bin games and i back to 9.9.
    Maybe somebody know is the AA problem was sloved by ATI
     
  6. Marcel Hulsbergen

    Marcel Hulsbergen
    #111 | Roaring Pipes Maniacs

    Messages:
    2,329
    Ratings:
    +22
    AA is ok here if i play on highest setting and also quality on max, but if i lower the quality then it gets worse, its a simbin feature lol.
     
  7. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
    Have you noticed any issues with Race 07 Marcel?
     
  8. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
    Just updated to the new drivers and the control center doesn't work :(
    Why bother with updating drivers as they fail all the time
    (Windows 7 Ati 4850 here)
     
  9. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
    Can you run a older version of the Catalyst control center with the new drivers?
     
  10. Jamie Blewitt

    Jamie Blewitt

    Messages:
    355
    Ratings:
    +50
    I updated to these drivers from catalyst 9.11 and my AF in Simbin games is fixed! On 9.11 it was broken. I use a HD4870 1gb on Windows 7 64bit. Dirt 2 runs more smoothly with these drivers too so thumbs up from me.
     
  11. Nigel Atkins

    Nigel Atkins

    Messages:
    3,019
    Ratings:
    +61
    CCC works fine here with the new drivers, you`ve obviously done something wrong :mad-tongue:
     
  12. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
  13. Nigel Atkins

    Nigel Atkins

    Messages:
    3,019
    Ratings:
    +61
    did you use driver sweeper in safe mode?
     
  14. Ben Tusting

    Ben Tusting

    Messages:
    5,764
    Ratings:
    +133
    I find the issue, Driver sweeper wasn't finding the Ati folder in my x86 program files

    Yeah i did use it in safe mode
     
  15. Bruce Saltzman

    Bruce Saltzman

    Messages:
    924
    Ratings:
    +17
    I first use Revo Uninstaller Pro to remove the drivers before going into safe mode. After that I go into safe mode and use driver sweeper. Then remove extra ATI directories while still in SM. Then after rebooting to normal desktop, run driver sweeper again to make sure, then run Registry Mechanic. Then install new drivers. Works every time with no problems. This is on Windows 7, 64-bit.