• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Netcode plague

Discussion in 'netKar PRO' started by Abdul Al-Amry, Feb 26, 2011.

  1. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19



    Very disappointed this hasnt been resolved yet after the update. Has happened to me on a few occasions already and I just started using this sim when 1.3 came out.
     
  2. Mattia Gottardi

    Mattia Gottardi

    Messages:
    1,021
    Ratings:
    +0
    yeah is a big shame.... i have more videos about that things:













     
  3. Kamran Choudhry

    Kamran Choudhry

    Messages:
    180
    Ratings:
    +7
    If I had time(and if I wasn't lazy:p) I'd show you my osella race on the last lap, nobody near me with a guy about 5-8 seconds ahead of me and my car goes flying lol! It was funny watching my suspension all broken up.
     
  4. Requiem84

    Requiem84

    Messages:
    361
    Ratings:
    +229
    The netcode has been horrible since NKP came out 5 years ago. To be fair, it was worse back then compared to now... now at least you can have some races. With version 1.0 it quite frequently happened that the race started and you didn't get the 'go to grid' button :D. We had ghost car issues, huge framedrops with more users connecting, crashing servers etc etc. This only has slightly improved during the years. I say this just to prepare you; it won't get much better....

    Unless Kunos hires someone for the netcode, or perhaps dedicates all his time to studying netcode, instead of working on physics and new cars...
     
  5. Andrew Scott

    Andrew Scott
    "Ye Old Convict" Premium

    Messages:
    1,570
    Ratings:
    +653
    The poor Netcode is hurting NKP's popularity, which is a shame, it has so much to offer.
     
  6. Paul Hamwa

    Paul Hamwa

    Messages:
    617
    Ratings:
    +0
    Yeah Karman I saw that happen you were in front of me a ways off. I think you might not have seen it, but you ran over a leprechaun! :p
     
  7. Tomas Torasen

    Tomas Torasen

    Messages:
    987
    Ratings:
    +95
    Not fun to hear =( But honestly guys.. I had so much problems before 1,3. But since 1,3 and I have not done many races online, but still some. And no problems at all. For me theres a big improvement in net code as I see it..

    No one agrees?
     
  8. Paul Hamwa

    Paul Hamwa

    Messages:
    617
    Ratings:
    +0
    I agree. The net code in 1,3 seems pretty ok, that is once the servers started showing up. --->Although I might eat my words after Suzuka tonight :p

    Anyway just try to find the perfect sim, it doesn't exist!
     
  9. Paul Hamwa

    Paul Hamwa

    Messages:
    617
    Ratings:
    +0
    ok how's this for timing, I just wanted to connect and practice, 0/1 Servers again! :eek:

    Anybody else having this again????
     
  10. Senad Subasic

    Senad Subasic

    Messages:
    8,711
    Ratings:
    +1,901
    All fine on my end.
     
  11. Paul Hamwa

    Paul Hamwa

    Messages:
    617
    Ratings:
    +0
    Crap!

    AHHHHHH There they are again, I rebooted three times. Hopefully I can connect tonight....otherwise you'll all have to face Laurent!:wink:
     
  12. Tomas Torasen

    Tomas Torasen

    Messages:
    987
    Ratings:
    +95
    servers seem to show up, but I just raced a mate online and we had some wierd lag. But both him and me had bad lines (which I wont have tonight at Suzuka). Cant really judge the net code then.
     
  13. Kamran Choudhry

    Kamran Choudhry

    Messages:
    180
    Ratings:
    +7
    I think netkar itself is just rather buggy, I have to restart netkar everytime one time to get vsync to work, and I have to go into controller settings twice for it to stop swapping my brake balance buttons around. The 0/1 server is probaly just another bug, good luck with that!
     
  14. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Messages:
    2,298
    Ratings:
    +19
    This problem is really spoiling it for us and the game itself. For a game that doesnt have any AI to race with I would have expected the netcode to be spot on. Developer should focus all his resources to solving it first before updating anything else imho. Any direct contact, twitter for Kunos?

    Its becoming scary racing close to one another on a sim that close racing is where its at.
     
  15. Andrew Scott

    Andrew Scott
    "Ye Old Convict" Premium

    Messages:
    1,570
    Ratings:
    +653
    The netcode sucks, and its killing the potential popularity of nKPro imho.
    Ive given up trying to race online, the only server I can use is Dean's 10Mbit, which is local, elsewhere my ping is always 3000, regardless of the server location and Ive always got that BIG black translucent box in my face, it's so dissapointing.

    Im so bored with nKP, theres a limit to how much solo lapping one can bare, Ive reached mine.
     
  16. Redvaliant

    Redvaliant
    Premium

    Messages:
    379
    Ratings:
    +34
    The Tyranny of Distance as Split Enz so eloquently said. I often see Japanese and Brazilian servers that have high ping to us in Europe so maybe these could work for you?
     
  17. Kilroy

    Kilroy

    Messages:
    5
    Ratings:
    +0
    Sometimes in the server listing you get ridiculous pings but once you connect to a race the pings drop quite a bit.

    Living in Australia and only having one Australian server showing up, which now seems to have disappeared, I don't have much choice and have to connect to European servers if I want to race. Most of the time the connections seem pretty stable although you always have to be aware how close you get to other cars. This is not unique to netKar though.

    One thing I have been wondering about is that in the earlier versions of netKar, when online at the start of a race, you would get a go to grid button in the garage. I don't get this anymore so if I'm in the garage making a change it puts me directly on the grid before I'm ready.

    Is there a setting somewhere that makes the go to grid prompt show up?
     
  18. Mikel Tapl

    Mikel Tapl

    Messages:
    119
    Ratings:
    +5
    It does there , you just go automatically to grid once race starts, but if you quit to garage it will show up bottom right.
     
  19. Kilroy

    Kilroy

    Messages:
    5
    Ratings:
    +0
    Thanks Mikel, I'll check that out later.