1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need to adjust lap time!

Discussion in 'Bob's Track Builder' started by rdmgarcia, Dec 1, 2010.

  1. Hey guys,

    My first track is about to be out the oven. Only two more objects to go... The only one thing that I need to fix is the lap times.

    I seem to be beating the real track record for about good 5-8 secs :D. This is way too much. The track scale is real and comes from google earth, so track length is accurate.

    I also tried do lower the grip level in the tdf file. This helped a bit to lower my lap time, nevertheless, I am still very fast with a grip level of 65% and the vehicle is hard to control and furthermore, race line gets a little unrealistic.

    Any thoughts????
  2. It's possible your track is a little on the short side, Google Earth images are not always exactly 100%.

    In the AIW file scroll down to the [Waypoint] section and check the 'lap_length' entry which will show the length of the track in meters in rFactor and compare to the real life length.
  3. Would the track length change from that which is shown on the BTB interface? I have always just made the layout of my track on BTB using a google image in the background and then just resized it to the know track size and had good success usign this.
  4. I will try this tonight.... The AIW file controls the AI's right? Would it also control my lap times? If the lenght from the track layout is different that what declared on the 'lap_lenght' parameter, would this last one override the first one??
  5. The AIW file has nothing to do with your lap times. The 'lap_length' entry shows how long your track actually is in rFactor, so if you compare that with the real life length you'll see whether it needs a bit of resizing in BTB or not.

    Butters99, I assume the length in rFactor would be the same as shown in BTB, but I haven't checked. I had to resize my Goodwood track just as you say to get it right.
  6. you guys are right

    That seems to be the issue.

    The rfactor track seems to be 845m and that's what the lap_lenght parameter is set to in the AIW file.

    Nevertheless, today I measured the track and computed its distance from real lap times and lap speeds, this is about 1127m

    Is there any way (not very painful and messy) to fix this issue? Considering the track is almost done :confused::confused::confused:
  7. Yeah, just a few clicks and you can resize it. Open the 'Move Nodes and Control Points' dialogue and click the resize tab, from there its pretty self explanatory. But you might have some problems with objects. Make sure to save a backup before you go and do this incase you break it ;)
  8. You could try using the resize option and have all the boxes ticked. Click the "Move Node and Control Points" on the task bar then on the pop up box click on the "Resize" tab. You will then see a box which you can enter the distance into enter it in there and then click go (make sure you leave all the boxes ticked).

    Just a tip I use when I am creating a track that I can view on google earth I use the create a path option and map a path along the circuit from start to finish. Then click on the measurement tab and change the measurement metric to meters. This would then be the number I would enter into the resize as explained before. Won't be exact but it will be close. It is usually fairly accurate failing that if it is a normal course you might be able to google the length of the track.

    Hope that helps.

    Oh well Mianiak beat me to it. Went away carried on typing then posted to see mianiaks post lol
  9. After about 7 days of re-work, I think I am back to the stage where I was before with the short track :) Now lap time is about 46s and that's more realistic!
  10. Thats great news one other thing you could have done would have being to alter the resistance rating in the TDF file. By incresing this figure you would be able to slow down the lap times as well.