1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

need some help with my wheel please

Discussion in 'RaceRoom Racing Experience' started by Rowddy, Oct 21, 2016.

  1. I have a Logitech g25 wheel for some years now i have RacRoomExperience on my PC for a long tiime from when it was beta. I have a powerfull game PC but since the latest microsoft upfates i cannot dive naymore in this game in all my other racing games it works perfect but here i just won't work any more (it used to work just fine) the thing is, it does not recognize my wheel anymore it keeps saying missing device therefor i cannot make a proflie etc.

    I checked everything drivers, hardware set-up on the PC you name it they all say the wheel works lol. Now i am running out of options i just do not know what to do anymore :9 cab someone help me please?

    regards Rowddy.
     

    Attached Files:

  2. Kenny Paton

    Kenny Paton
    Embarrassingly, Backmarker Champion 2015 & 2016 Staff Premium Member

    It may be that your windows update has replaced the G25 drivers with the newer 920 ones, you need to get the lgs510_x64.exe from August this year and delete the current drivers. Then don't let W10 automatically update third party drivers.
    Make sure you have the profiler running.
    On the loading screen it mentions Logitech wheels have a read at that.
     
    • Like Like x 1
  3. Ok either i do something wrong but it still no works only sees the keyboard and says G25 is a missing device i can however make a new profile (could not do that before either) but then again it does not recognize my wheel :(
     
  4. Ok either i do something wrong or there is another problem i downloaded the suggestie friver but the result is the same it is still a missing device and it only sees my keyboard. I deinstalled and redownloaded and reinstalled now 4x the game but the problem stays i deleted the profile in the Logitech profiler and made a new profile for the game, nothing helps. it's just to crazy a few months ago the game and the wheel worked just fine... ( i have no clue how to fix this anymore :(
    anyone got an other suggestion?
     
  5. lol ignore 1 of the 2 posts please
     
    • Like Like x 1
  6. Kenny Paton

    Kenny Paton
    Embarrassingly, Backmarker Champion 2015 & 2016 Staff Premium Member

    Sorry I can't think of anything else, my G25 works fine, but I'm on W7 and I know that others with G27s are running them on W10.
    Have you tried the S3 forums?
     
  7. S3 forums i don't know them :( but txs for your help anyway m8 much appriciated :)
     
  8. 4 8 15 16 23 42 108

    4 8 15 16 23 42 108
    Only the 5th-most famous race driver from Kerpen Premium Member

    Have you deleted all wheel-related in device manager and registry?
     
    • Agree Agree x 2
  9. not sure tbh my Pc is dutch so these english terms as device manager i have no clue where to find that tbh. or how to accrs the registry although it seems a nit easier to me at least i have an idea of where that is lol
     
  10. Phil Davies

    Phil Davies
    Fix it till it's broke,Then fix it some more. Premium Member

  11. Andy Jackson

    Andy Jackson
    Sponsored by BRUT Premium Member

    Delete your Simbin folder in my documents/games. Delete the whole game. Re-install via steam and hey presto. It just might work again. Basically also try and delete all your wheel profiles in game controller menu too.
     
    Last edited: Oct 22, 2016