• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Tracks Need help with track import

Discussion in 'Assetto Corsa Modding Discussions' started by QVD, Aug 5, 2017.

  1. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Hello all,

    As many people have recommended, I tried making a very basic track before I dive in. However, I can't seem to open the fbx file in ksEditor like many YT videos can. The track is way off and I can't navigate to it. I have the UV mapped and properly named road and minimum spawn objects but still can't figure out the ksEditor UI. I am experienced in Rhino so I prefer that over Blender or RTB and was hoping someone could help me set up / analyze my basic track before I commit to spending countless hours building my intended track. Any help would be greatly appreciated! Here's the track link: https://mega.nz/#!JzpjjLZJ!KjcmFJ-oHkc0f58L4OfnHBeq6dupCHb_AT91XqOHn1E
     
  2. Matyeah

    Matyeah

    Messages:
    33
    Ratings:
    +48
    I imported your model into 3ds max and it was orders of magnitude too small. I don't know anything about Rhino, but try resizing your model by 100x, or adjust the export options. Also, road mesh had upside down normals, but that could just be due to some export/import catch.
    EDIT: Actually everything above is wrong lol, the model is fine. Just add some textures and make sure ksambient value is not 0 so the model isn't fully black.
     
    Last edited: Aug 6, 2017
  3. Stereo

    Stereo

    Messages:
    2,349
    Ratings:
    +1,372
    If you double click an object in the list on the left (it's a tree, expand it) it should move the camera to point at it.

    By default if it doesn't find a texture it makes stuff transparent so you might not see it, try loading textures on the materials tab also.
     
  4. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Thanks! Ambient, flipped normals and incorrect material mapping did the trick. However, once I load the file, error messages are gone, but the track won't load. I copied the rest of the files (.ini's) from other tracks and wonder if it's that. Sorry to be such a noob, I feel like I'm close to a solution! Here's the link: https://mega.nz/#!NjZWlZ4Q!fTmH0jcp_oKL7LKdT285J946BHTlCngc_g4GTgKfs8I
     
  5. Matyeah

    Matyeah

    Messages:
    33
    Ratings:
    +48
    Your boxes are not properly named, so the game can't load spawn points. They are called obj_000X when they should be named AC_PIT_X etc. You named the materials instead. The road mesh is named correctly.
     
  6. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Thanks for helping me troubleshoot this! Now I'm in AC and I can see my track, except the car is flipping in the air. The AC_START nodes are 1-2m above the track. Is there a material setting I have to change in ksEditor?
     
  7. Matyeah

    Matyeah

    Messages:
    33
    Ratings:
    +48
    Cars spawning badly is usually caused when models are oriented wrong. You should set Y axis for boxes to point upward, then Z will determine forward orientation.
     
    • Agree Agree x 1
  8. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    I'm wondering if it's something else, since exporting from Blender to ksEditor has the option to set the Z forward and Y up. Can objects in the same scene have different axis orientations?
     
  9. Matyeah

    Matyeah

    Messages:
    33
    Ratings:
    +48
    When you rotate origin/pivot point you change axis orientation of an object. If you think you set it correctly, then it's something else that's causing the problem. Are you running the practice mode? If so you will spawn in AC_PIT_0, so if that object is not above a physical surface car will just fall down into the endless abyss!
     
  10. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Wow. No matter how long I research and how many times I try to figure it out myself, you manage to come up with the simplest solution! Yes, it was in practice mode above a non-existent pit lane. I'll try this evening and let you know. Once again, thanks for your help, Matyeah.
     
  11. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Hi all,
    So, I'm at wits end. I tried everything you suggested, Matyeah, and even built a simpler track just to start clean and in both files, the car is spinning in the air and the engineer is parallel to the ground or the tires are messed up. Testing is tedious, time consuming and unmotivating. I hate to keep asking for people to check my work, but I feel like I'm spinning my tires (pun intended) on something that seems relatively straightforward. I know the problem arises from starting in Rhino to Blender to ksEditor, but as mentioned before, I am efficient in Rhino and can't wrap my head around Blender. I'm considering building the base track in RTB then customizing it further in Rhino (is that possible?) as my last ditch attempt. Anyways, I would be grateful if anyone can have a look at my file(s). They are ready to be dropped into ..content/tracks for testing. Disregard the map and UI files as they are lifted from Zaandvort for the sake of testing. Also, disregard the track names -I needed a placeholder.

    Original: https://mega.nz/#!cnBQzKIK!nDbgNsr61eFsOfFk3SIn3zaFqJknGQCEn5R_hz_NBzE
    Simplified version: https://mega.nz/#!YnJhDLJB!Y7AGVGcQ48cc4O-b8eM3cqdFqGztL_jxmx0b96m-FXY
     
  12. Fat-Alfie

    Fat-Alfie

    Messages:
    526
    Ratings:
    +1,105
    Working simple version:

    https://www.dropbox.com/s/ab4a7f0m919io5m/Wazoo.zip?dl=0

    1. Remove unnecessary files from the data folder if you use an existing track as a starting point (especially camerafacing.ini)
    2. Remove any .ai files from AI folder too (also causes crash)
    3. Your AC objects were orientated correctly but the axis was at world 0, 0, 0 instead of the centre of the object.
    4. Don't use .jpg files for textures, but rather .dds
     
  13. QVD

    QVD

    Messages:
    7
    Ratings:
    +0
    Thanks, Alfie! I'll check it out tonight. Where did you learn about creating the *.fbx.ini file?
     
  14. Fat-Alfie

    Fat-Alfie

    Messages:
    526
    Ratings:
    +1,105
    I just used 3dsimed to import your .kn5 and then exported the .fbx to edit it in 3ds max. 3dsimed will export the .ini if you ask it to.