1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Need help with multiplayer

Discussion in 'F1 2013 - The Game' started by Poo', Apr 28, 2014.

  1. hey guys i need a help with my game:
    I can't play multiplayer since yesterday(PC). cannot join online session, cannot create online session(game back me a messege: you have failed to create a session lobby) in custom race. Then i try quick match and get a messege: you must be signed into steam. make sure you're online mode and make sure your connection is ok.
    What's wrong with my game?
     
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    It's your Steam connection, nothing to do with the game.

    When the Steam servers drop off, which has happened too often recently, you will get an error like this.

    I have been playing other games, and been dumped out of them, just because the Steam servers have momentarily dropped off-line, then back up again.

    Make sure that you are logged into Steam when you start it. Go to the the top left Steam Menu and make sure you have On-line mode selected (not off-line).

    If you cannot get on-line, then either the Steam servers are down, there is something wrong with your connection, or your firewall/router is blocking connection.

    Cheers
     
  3. Thanks for reply
    I think i have fix it. add -tcp to steam launch option then everything is ok. there is really something wrong with my connection.
     
  4. Can you explane the tcp-thing??

    I have the same problem
     
  5. i tried this,..
    i opened some ports...
    Put my PC in DMZ-mode...
    did a clean installation of the program... but...
    I cannot play multiplayer
     

    Attached Files:

    • Doc1.pdf
      File size:
      100.1 KB
      Views:
      82
  6. Jesus, don't put your PC into DMZ (which isn't a real DMZ for most routers anway just an Exposed Host, provider based routers won't even work properly often, like easybox from vodafone which tends to keep UDP ports closed). Opening ports when the PC is in DMZ doesn't do anything.
    Plus setting inbound rules when you need outbound rules seem wrong, don't you agree?
    https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711

    A good router only needs activated UPnP to get this stuff done.

    If there is no MP issue over other steam games, try connecting your F1 2013 to CM's racenet ingame.

    (I suppose windows itself is not blocking anything, right?)

    Well, Tom had this issue last year, err he disabled his router's firewall (I would never suggest doing that if not for quick tests). But there is said to be an other guy who came up with a different solution:
    http://www.racedepartment.com/forum/threads/multiplayer-ports.58599/page-2#post-1284984
     
    Last edited: May 4, 2014
  7. I have the new Dlink 868L, wich supports upnp.
    The DMZ was only a test.
    I can connect with racenet.
    I can play other games (steam)
     
    Last edited: May 4, 2014
  8. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

  9. I did a fresh reinstall and now it works..

    Thx
    for the support
     
    Last edited: May 5, 2014
    • Like Like x 1
  10. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Of Steam or the game?

    Please don't say operating system :D
     
  11. Looooooool

    Erased everything of F1 2013 and a reinstallation of F1 2013.
     
    • Like Like x 1
  12. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Thanks :)

    It might be useful information for others who might read this thread
     
  13. Uhm, did you try deleting
    AppUpdateStats.blob
    ClientRegistry.blob
    once separately like it was mentioned it that topic I linked?
     
  14. Yes, i did that also. But no solution
     
  15. Only design mods, like skins (car livery, helmets), maybe frontend (menu pictures). No database, no pssg edits, not sure about xml edits, some work, some don't.
     
    • Like Like x 1
  16. Hm, I think pssg edits should work. So a custom OSD, circuit changes (design only) and maybe even switched cars (like tr2 based on mc2) should be usable online.
     
    • Like Like x 1