1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help wiht my T500 TH8RS shifter

Discussion in 'Sim Racing Hardware' started by 2re, May 14, 2014.

  1. 2re


    Hi guys.

    My TH8RS shifter has suddenly become sluggish, its hard to push into gear and it feels like metal or perhaps the shaft is grinding somewhere.
    I opened it up but couldn't find anything wrong with it and there was plenty grease in the shift mechanism and it worked fine when I tried all the gears, holding it in my hand.
    I put it back together and it worked like a charm for ca30min then it started to grind again.
    I don't want to open it again unless I know what to look for.

    If anyone know what the problem is and how I can fix it, please let me know.

    Kind regards

  2. 2re


    Thanks for the tips, it worked ;-)

    That thread is 62 pages long. I read 20 of them before I found something about a tension screw.

    I goggled it and found the TH8RS manual.
    Turns out it can be accessed from the outside thru a hole and Its used for tightening or loosening up the shift resistance.
    It worked, the shifter is smooth as silk again.
  3. Yea I knew about the tension screw but I wouldn't have thought it was causing a grinding noise.
  4. 2re


    All is not well, the tension screw seams to be tightening up again after some use.
    I'll take it a part and clean and apply some grease to the mechanism.

    Thanks again for helping