1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC need help adjusting pedals

Discussion in 'Assetto Corsa' started by Reik Major, Jan 5, 2016.

  1. Reik Major

    Reik Major
    Premium Member

    Hy folks!

    I own such a black Momo (Logitech) FFB wheel and it seems to me AC doesn't make use of most of the travel range from my pedals.

    No matter what I play around with settings, it appears the cars give full throttle when pressing just ~ 10-15% on my throttle pedal. In such a short range it's impossible to apply the right amount of power to propperly accelerate out of corners or catch a drift or do drifting on purpose. Cars like the Cobra are impossible to handle, so half of the amount of great cars are no fun to drive at all. :(

    On the other hand the ingame graph from the app and the indicator in the controller options tell me, that the whole pedal range gets used. This contratiction makes me clueless. :cry:

    I'm absolutely helpless in the question if there's a problem with the game/hardware (adjusting it or even a bug?) or if it's just me.

    Please don't get me wrong. I don't expect too much from my old hardware but in other games I was always able to apply the power carefully making use of the whole pedal range. I also consider myself an experienced sim racer so I really wonder why I shouldn't be able to controll such cars when others do.

    Please help me out, because I'm finally in doubt about my own skills and so far I used to enjoy the quicker cars more than the slower ones.
    Last edited: Jan 5, 2016
  2. Ricoow

    420 Premium Member

    Have you fully pressed all your pedals before trying this?
  3. Reik Major

    Reik Major
    Premium Member

    Not sure if I get you right. If you mean pressing the pedals fully when ingame like turning the wheel completely to calibrate it the answer is YES.
  4. Matheus Machado

    Matheus Machado
    #17 Talking Door Racing Staff Premium Member

  5. Reik Major

    Reik Major
    Premium Member

    I do so.

    Thank yo very much. Will try it asap.
  6. Sounds obvious but have you run the setup wizard in the game? On the FFB screen there is a button at the top left. In there it asks you to press each of your pedals in turn etc.
  7. Reik Major

    Reik Major
    Premium Member

    Thx for your help. Yes it was the first thing I did when I got into AC. Everything there went right but I have the described "problem" from the first day. Still didn't find the time to follow the other advices given earlier here...
  8. Dan ONeill

    Dan ONeill
    Premium Member

    Is it just the throttle pedal? This could indicate a faulty sensor. Obviously it's unlikely the case if all three are like that...

    Have you calibrated in Windows? Perhaps uninstall drivers and reinstall?
  9. Reik Major

    Reik Major
    Premium Member

    thx for helping. After checking my brothers wheel, which is the same, I think it's just the outdated hardware, so I think I have to get used to it...