1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

My second T500 just died on me

Discussion in 'Sim Racing Hardware' started by Boby Kim, Oct 20, 2016.

  1. Boby Kim

    Boby Kim
    There is no spoon... Premium Member

    Just two seconds ago my second T500 died on me:(. I was racing and out of the blue the FFB went dead. I thought it was just another USB failure but whatever i do, there is no life...no green light...nothing.
    My first T500 died with a puff of smoke. I send it back to TM and received a completely new base. That was about...one or two years ago?
    So yeah...now what? I probably sent it back again:cautious:.
     
    • Sad Sad x 1
  2. Andy Jackson

    Andy Jackson
    Sponsored by BRUT Premium Member

    Fuze in the plug maybe?
     
  3. First thing to check is whether the power brick has a light on or not...
     
  4. Boby Kim

    Boby Kim
    There is no spoon... Premium Member

    Few month ago i replaced the original fan with a Noctua. This weekend i will open it up en start some measures.
    The power block is also to the end of its life as sometimes the power led is on...then off.
     
  5. 3 minutes after I tried him :


    ahah
     
  6. Boby Kim

    Boby Kim
    There is no spoon... Premium Member

    This is strange...
    When the wheel quits during racing it shuts down the power: the mode led is off. No matter if i replug in the USB...mode led wont go on. I have to unplugg the power...wait a few second and plug it in. After that the Wheel comes alive again. It calibrates and i can start racing again. But it will happen again.
    The solution is: uninstall the driver, restart PC, install driver and i can race for 60 min. non stop woithout any problems. Untill i stop racing, power off the PC...coming back later to race and it quits working again. I have to unplugg the power, plug it back in, uninstall the driver etc.
    Same post went to Thrustmasters. See how they respond
     
  7. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium Member

    Is USB power management disabled for the device? Have you tried with the wheel fan on always on? It might be overheating and hitting thermal limits. Or the fan might not draw the same amount of power, have the same rpm or supply the same amount of air as the factory fan.
     
  8. Boby Kim

    Boby Kim
    There is no spoon... Premium Member

    USB power management is disabled.
    I was also thinking about the fan. But the problem disappears when i uninstall and reinstall the driver. Once i turn off the pc and back on the problem reappears.
     
  9. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium Member

    Hmmm... Is it plugged into USB2 or USB3? Can you try in another port? If it's only appearing after reboot, it might be that the BIOS initializes the device incorrectly, and when you reinstall the driver, it gets initialized again. Or Windows has different driver versions installed and keeps assigning the device to the wrong one. This could be checked if you remove the wheel from withing Device Manager and tick 'Uninstall drivers' when prompted, then let the system reboot.

    Still just brainstorming though, I have no solid idea, never even heard of such, even though I'm long into IT professionally.