1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

My monitor hz is locked at 60!

Discussion in 'F1 2010 - The Game' started by Finkstaa, Aug 26, 2011.

  1. Hello, i'm having an issue with the refresh rate on f1 2010. Basically i change it to 120 in the options which it tells me it has done but my monitor tells me its running at 60. This is pretty annoying as my monitor supports 120hz and should run it at any resolution but i can't get it to change to anything but 60. Has anyone had this problem and know a fix for it?

    The monitor is an LG W2363D 120hz 3D

    Setup - i5 2500K Sandybridge
    4gig Corsair vengeance Ram
    ATi HD6770 1gig

    Any help would be appreciated
     
  2. No it isn't. Explain how i manage to run every other game at 120hz except f1 2010. A game which used to run at 100hz on my old monitor.
     
  3. Nope. Although 120hz is REQUIRED for 3D its not specific to 3D or Nvidia.

    Assuming the monitor settings are correct, I suggest checking you are using a dual-link DVI cable.


    EDIT - ah sorry you must be using one if other games are working in 120. Our posts must have crossed.
     
  4. If you look at the monitor he is talking about you'll see that it is a true 120hz monitor i.e. It can run at 120fps without any nvidia goggles. The truth is when you plug in the nvidia goggles you nerf your systems specs (pun intended) to what the glasses can handle. Once again nvidia is supplying substandard products...

    OP: As this game is a very poor port from consoles it is probably limited to 60fps max regardless of the refresh rate of your monitor. The only hope is that F1 2011 PC isn't restricted due to the less powerful consoles poor fps rates.
     
  5. Hey Paul, i am using a dual-link DVI cable, as i said it just seems to be F1 that won't run at anything above 60hz at present, every other game is fine. Thanks for the response though.
     
  6. Yeah i maybe should have been clearer in my original post as i think i have confused people into thinking i am trying to run the game in 3D (which i'm not) I'm just running it like i would any other game no 3D goggles or any of that jazz. I think i'd only use the 3D feature on the monitor for movies in all honesty.
     
  7. Yes sorry mate - I took so long to post that reply that I didnt see your further information!

    I'm with Justin, in that I suspect 2010 is actually the problem. Which is surprising in such a bug free game!! [/sarcasm] :D :D
     
  8. No problem mate, i think that you are right with F1 being the problem (surprise surprise), it's not a problem that will ultimately stop me from playing the game its just i have a setup capable of running at the "120hz" but the game won't let me do so, just a bit frustrating. Before making the thread i did have a browse of google to see if anyone else had a similar issue, didn't really turn anything helpful up other than there was supposed to be a game update that fixed this issue, would appear that's not the case :-/

    Thanks for the responses anyway fellas.
     
  9. I have to ask, but are we confusing Hz for FPS? Do you have v-sync on?

    *edit* apparently I took very long to write my very short response and have been ninja'd
     
  10. If you read the thread properly you wouldnt have to ask :D
     
  11. Hello Lenard, the issue is indeed with Hz and not fps and i have v-sync off. I even tried with it on but no change.
     
  12. Nope I would still have to, same way when working IT and get a call for a non working machine still have to run through the "is the power on, is it plugged in, is the monitor on, is the monitor plugged in, is the monitor plugged into the machine, are you wearing a blindfold that is restricting your ability to see. Only once all of that is answered, do you leave your desk and start to diagnose
     
  13. I do have a further thought actually!

    Obviously 120hz monitor caps FPS at 120 - Anything over and above this can cause 'tearing' which is why you can limit your GFX output to the native Hz of your monitor using V-synch, be it 60, 70 or 120hz.

    In order to attain true 120hz on your display, you need to be able to supply the monitor with 120FPS - and I think thats where your problem is.

    I built an i5 Sandy rig 4gb RAM, very similar to yours except instead of a single 6770 like yours, I put 2x 6970's in there.

    This was the benchmark results -

    F1 2010 everything maxxxed @ 1920x1080

    i5 @ 3.3ghz (stock)
    1920x1080 DX11 Single = 56 FPS
    1920x1080 DX11 CrossF = 82 FPS

    i5 @ 3.7
    1920x1080 DX11 Single = 57 FPS
    1920x1080 DX11 CrossF = 93 FPS

    i5 @ 4.3
    1920x1080 DX11 Single = 58 FPS
    1920x1080 DX11 CrossF = 100 FPS

    Soooo, Im thinking that your GFX card just isnt up to kicking out enough frames in F1 2010.

    Just to give you an idea of how demanding F1 2010 is.....

    Battlefield Bad Company 2 @ 1920x1080 maximum detail etc -

    i5 @ 3.3ghz
    Single = 70 FPS
    Cross = 135 FPS

    i5 @ 4.3ghz
    Single = 74 FPS
    Cross =145 FPS

    I rekon F1 is seeing your 120hz monitor and letting you set the option, but your GFX card just doesnt have the power to chuck enough frames out to make it happen.

    Hope this info helps. I prescribe a second 6770 immediately :D :D