• "Slow and steady finishes the race. Fast and steady wins the race." - Sean Rogers.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MP

Discussion in 'rFactor 2' started by Craig Stevenson, Jun 25, 2013.

  1. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    I'm wanting to try MP with a couple of mates but from what I understand I can't just run a DS as with Race and rF1, I now have to build a Mod, is that right?, if so how do I do this and why can't we just Host a DS like before?

    I've done a fresh install today of build 228 on both the Server and Gaming rigs and want to race the Clio's on a few tracks I have installed.

    Regards

    Craig
     
  2. Bram

    Bram
    Administrator Staff Premium

    Messages:
    41,950
    Ratings:
    +16,173
    Not sure why you need to use such language while asking a normal question but okay.

    Yes you do need to build your own mod to host races online. Before in rFactor 1 it was mismatch heaven and ISI has tried with this system to avoid that I think. Not handy but it works.

    Makes the appreciation for our staff even greater for hosting daily races and have to do a lot of work behind the scenes to build all those mods for everybody to enjoy. Don't think many people know how much time they spend setting everything up every week :)
     
    • Like Like x 3
  3. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    Apologies for the language in the post Bram, I was tired after spending several hours trying to figure out why I couldn't see my rF2 Server and being lead down the route of Port Forwarding etc which I've NEVER had a problem with before. Shortly after posting the above I found the pretty simple instructions for creating a Mod which then showed up on my Server, I still have a couple more things to do but I'm now moving in the right direction and will hopefully have the Server running tonight.

    Regards

    Craig
     
    • Like Like x 1
  4. Craig Stevenson

    Craig Stevenson

    Messages:
    918
    Ratings:
    +141
    My server runs fine now but I still seem to have an problem or two.

    1) If I try and Run "rFactor2 Dedicated.exe" directly I get an error about No Mod Files or Installed Mods Found, the server runs fine via the Host button on main UI.
    2) Using the "Host" button on the main interface I can only see "player" in the player selection drop down, if rF1 that showed my profile name.

    Any suggestions?
     
  5. Ho3n3r

    Ho3n3r

    Messages:
    4,997
    Ratings:
    +1,491

    Sounds about right, that is how it works at the moment.