• Racing is not a matter of life and death. It's much more important than that!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Motec XD overlay from GTR useable in rF?

Discussion in 'rFactor' started by Reik Major, Jul 9, 2010.

  1. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    hy everyone!

    I wonder if there's a way to use the Motec XD overlay from GTRevo either with rF. I'm so used to it and i thought it could be possible, because i think i read something about it a very long time ago.
    Any suggestions?

    thx mates!
     
  2. Ivo Simons

    Ivo Simons

    Messages:
    11,357
    Ratings:
    +953
    Yup its possible. Just drop it in the rFactor main folder. :)
     
  3. Mattia Gottardi

    Mattia Gottardi

    Messages:
    1,021
    Ratings:
    +0
    yep it works perfect with rfactor m8!!! ;)

    i'm using it with the map plugin and it works great!!!! ;)

    if you want use only the XD motec than is pretty easy.....you need to put the d3d9.dll files into the rfactor folders.....but remember that in this way you can't use other type of plugin that use the d3d9 files apart the map plugin (so you can't use XD and f1 style plugin)!!! ;)
     
  4. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    Cooooool!!!! Thank you both for quick info! Nice support here!
     
  5. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,888
    Ratings:
    +923
    nice, that solves the next problem I was going to address.
     
  6. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    I don't know what i do wrong, but i can't get it to work. I don't think i have any other plugins, that use the d3d9 file.

    I tried different ways without effort :frown:

    1.
    Just copied the d3d9.dll and the XD.ini from my Evo install into the main folder of rF - didn't work

    2.
    deleted those files from point 1, then copied only the d3d9 file from the original downloaded zip into rF folder. It didn't apear in the game, but after leaving the game the XD.ini has been created and ways there.

    Waht do i exactly have to do to get it working? I need this overlay...

    Should i name you the other dll's i have there, so you can see if there's an other file which is disturbing the overlay?
     
  7. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,888
    Ratings:
    +923
  8. Ivo Simons

    Ivo Simons

    Messages:
    11,357
    Ratings:
    +953
    Your running DX9 mode?
    You have the DVD version of rFactor?
     
  9. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    thank you Dave! will have a look, but first priority is to get XD overlay to work, because i'm so used to it...

    ÄHM...... atm i'm using a "not so official" version by friend. That's why i'm not online till now. But i'll by an own one soon. So i think it's not a DVD version.

    About DX9: Where to look which mode i'm running? in the rF setup or so?
     
  10. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,888
    Ratings:
    +923
    Yeh its taking me a little while to get used to reading the data it provides quickly enough to not make me crash :D

    Yes Reik you find the DX mode in the seperate setup program. It's basically the same as the Race 07 graphics options program you will have seen before.
     
  11. Ivo Simons

    Ivo Simons

    Messages:
    11,357
    Ratings:
    +953
    rFactor config in the main folder.
     
  12. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    Are you having a clinch about "who makes me happy first"? :redface:

    Sorry guys, i have a girl friend already, but it's great to get so much support within some minutes. :tongue: :doublethumb:
     
  13. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,888
    Ratings:
    +923
    lol not really Reik, you can work it out for yourself if you prefer :p
     
  14. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    Ohh no! Just kidding.

    Better two infos instead of no one!

    thx

    Edit: I'm at work now, so can try your tipps on evening - hope i get it done...
     
  15. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,888
    Ratings:
    +923
    heh :wink::good:
     
  16. Mattia Gottardi

    Mattia Gottardi

    Messages:
    1,021
    Ratings:
    +0
    remember to download the upgrade that you can found here.

    http://www.rfactor.net/index.php?page=downloads

    download the "exe only"!!! ;)

    i solve the problem with that!! ;)

    and it works also with a "not so official" version by friend

    in every case if you still have problems i will upload the files and i will send you a pm!! ;)
     
  17. Ivo Simons

    Ivo Simons

    Messages:
    11,357
    Ratings:
    +953
    Yup you need probably install the F version wich you need always with a DVD version. But probably also with your "version".
     
  18. Reik Major

    Reik Major
    Premium

    Messages:
    2,781
    Ratings:
    +3,673
    Guys your support is outstanding here! Fantastico....
     
  19. Mike McCormick

    Mike McCormick

    Messages:
    38
    Ratings:
    +3
    Reinstall Direct X after you install it.

    It's in the rFactor/support folder.
     
  20. Jerry Schwanebeck

    Jerry Schwanebeck

    Messages:
    25
    Ratings:
    +0
    Isn't there an F version with sound files? I would recommend that one. Or else you will be back asking for help on missing sounds from certain cars.