1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MoTec and my GTRe .PLR file

Discussion in 'RACE 07 - Official WTCC Game' started by Steven Palmer, Oct 12, 2008.

  1. Ok here's my problem. I have installed MoTec and changed the necessary lines in the .PLR file to the following

    Data Acquisition Rate="10" // rates 1, 2 ,5, *10*, 20, 50, 100
    Data Acquisition In Race="1"
    Data Acquisition EXE="E:\Program Files\MoTeC\i2\1.0\MoTeC.exe"
    Data Acquisition File="E:\Program Files\Valve\Steam\SteamApps\MY NAME HERE\race 07\UserData\vehicledata.spt"
    MoTeC LogFolder="E:\MoTeC\Logged Data"
    MoTeC Minimum Time="20" // minimum MoTeC recording time (sec)
    MoTeC Multiple Logs="1" // generate unique filename for each new log


    I then save the file, Run GTRe, do a few laps in the practice session, go back into the pits, Alt Tab out Start MoTec and try to open the log file, trouble is whenever I look there are never any logs.

    I re open the .PLR file and all the lines that I have changed above have gone back to their original state

    Data Acquisition Rate="10" // rates 1, 2 ,5, *10*, 20, 50, 100
    Data Acquisition In Race="0"
    Data Acquisition EXE=""
    Data Acquisition File="userdata\vehicledata.spt"
    MoTeC LogFolder="MoTeC\Logged Data"
    MoTeC Minimum Time="20" // minimum MoTeC recording time (sec)
    MoTeC Multiple Logs="1" // generate unique filename for each new log


    Am I doing something wrong here?

    Has anyone experienced the same thing?

    Thanks in advance :p
     
  2. Well, I have it working fine so I'll show you how I've done it:

    I've only changed what is in bold font.

    Data Acquisition Rate="10" // rates 1, 2 ,5, *10*, 20, 50, 100
    Data Acquisition In Race="1"
    Data Acquisition EXE="C:\Program files\MoTeC\i2\1.0\MoTeC.exe"
    Data Acquisition File="userdata\vehicledata.spt"
    MoTeC LogFolder="C:\Program files\Steam\SteamApps\My Steam name\race 07\Motec\Logged data"
    MoTeC Minimum Time="20" // minimum MoTeC recording time (sec)
    MoTeC Multiple Logs="1" // generate unique filename for each new log

    Try with this configuration. Remember that the ".ld" files (where the data is contained) are stored in "MoTeC LogFolder".

    Obviously you can put "MoTeC LogFolder" wherever you want:becky:
     
  3. did you tryed to make the changes and set the file afterwards to read only so steam cant overwrite ?
     
  4. No, I only made the changes, started GTRe, a couple of laps in a practice session and there was the file. I don't know why the .PRL file went back to its original state. I have just checked my .PRL file and it isn't read only. Maybe I'm saying a nonsense, but could it has been changed by an automatic system recovery?. I have it disabled.
     
  5. Steam/Evo will have rewritten the file.

    Make the changes and then make it read only so it cannot be rewritten, then try again.
     
  6. Thanks, I'll try write protecting it tonight. :becky:
     
  7. Here is mine

    Oh and my .PLR file is not write protect...

    As you can see, I had MoTeC already installed for GTR2, so it is pointing there for the .exe ...

    hope that helps...
     
  8. I solved this by creating a folder called MoTec in the Race 07 directory and creating another folder inside this called Logged Files so the path matched the .PLR file.

    Works a treat.
     
  9. Yep, Gunthar cheers that worked for me, i.e leaving the line Data Acquisition File="userdata\vehicledata.spt" as it was and leaving the file NOT write protected. Now I just need to read up on what it all means :rolleyes:
     
  10. Ok guys, after reading this very imformative thread I got motec working on my system for GTRe.
    My problem is that not all the fields are being stored by Motec. When I look at the Motec output I am missing things like tire temps and brake temps.
    I had a thought that perhaps it is because I am running the Motec XD 2 program so it won'tcarry over the parameters that are being measured there.
    Any body got any thoughts?
     
  11. It shouldn't be that as I run XD, also use Motec i2 pro and have all the data chanals you are missing.
     
  12. Yes, you are correct. I uninstalled XD and the missing data channels still were missing. Has anybody else got any idea's.
     
  13. Well, assuming you have a similar plr file to those above and that you are running Motec i2 pro...

    For "Motec output" you mean the data in the log (ld file that goes into the Root:Motec/log folder? (You have the log file but in there some chanals are blank)

    Are you doing a fully new project?
    Are you using a DL (from the iNet) project?

    Shooting in all directions here :wink2:
     
  14. can not get Motec to work in Race07 I'm using mi2_pro-wxp_1.01.0082
    and this my PLR file
    Data Acquisition Rate="10" // rates 1, 2 ,5, *10*, 20, 50, 100
    Data Acquisition In Race="1"
    Data Acquisition EXE="C:\Program Files (x86)\MoTeC\i2\1.0\MoTeC.exe"
    Data Acquisition File="C:\Users\Chris\Documents\SimBin\RACE07\UserData\vehicledata.spt"
    MoTeC LogFolder="C:\Users\Chris\My Document\MoTeC\Logged Data"
    MoTeC Minimum Time="20" // minimum MoTeC recording time (sec)
    MoTeC Multiple Logs="1" // generate unique filename for each new log
    Can anyone help?
     
  15. Well, I have it working fine so I'll show you how I've done it:

    I've only changed what is in bold font.

    Data Acquisition Rate="10" // rates 1, 2 ,5, *10*, 20, 50, 100
    Data Acquisition In Race="1"
    Data Acquisition EXE="C:\Program files\MoTeC\i2\1.0\MoTeC.exe"
    Data Acquisition File="userdata\vehicledata.spt"
    MoTeC LogFolder="C:\Program files\Steam\SteamApps\My Steam name\race 07\Motec\Logged data"
     
  16. Motec can be a pain to get to work some times. The place set to save the data is important as is the log information. You may have to adjust what the readme says about the install depending on what version of windows you are using. When I used Motec, I had to spend a bit of time working on the PLR file to get things to finally work for me.
     
  17. All BD-ROM application files are stored under a “BDMV” directory.[81][82][83][84]
    BDMV directory: contains the PLAYLIST, CLIPINF, STREAM, AUXDATA and BACKUP directories.
    • PLAYLIST directory: contains the Database files for Movie PlayLists.
      • xxxxx.mpls files: store information corresponding to Movie PlayLists. One file is created for each Movie PlayList. The filenames of these files are in the form “xxxxx.mpls”, where “xxxxx” is a 5-digit number corresponding to the Movie PlayList.
    • CLIPINF directory: contains the Database files for Clips.
      • zzzzz.clpi files: store Clip information associated with a Clip AV stream file. The filenames of these files are in the form “zzzzz.clpi”, where “zzzzz” is a 5-digit number corresponding to the Clip.
    • STREAM directory: contains AV stream files.
      • zzzzz.m2ts file: contains a BDAV MPEG-2 transport stream. The names of these files are in the form “zzzzz.m2ts”, where “zzzzz” is a 5-digit number corresponding to the Clip. The same 5-digit number “zzzzz” is used for an AV stream file and its associated Clip information file.
      • SSIF directory: If used, Stereoscopic Interleaved files shall be placed under this directory.
        • zzzzz.ssif file: is a Stereoscopic Interleaved file that is composed from two BDAV MPEG-2 transport streams. Both of the streams include an MPEG-4 MVC view video stream for left eye or right eye respectively. This file is used only when 3D video is played back. The 5-digit number “zzzzz” is the same as the number used for the AV stream file “zzzzz.m2ts” that includes the MPEG-4 MVC Base view video stream.
     
  18. Since the first version I questioned myself for the capacities of my program to work correctly on Vista and Windows 7, but it was always compatible with all windows platforms, the problem came from the library of licenses management (in DLL only).

    I would like to thank Super-Efix, an administrator of league who put in evidence this problem by discovering that the DLL generated one different ID from the server (a disaster obviously :-/ ).

    I would continue to 'doubt' of my code for improve it, but now I would not hesitate to doubt for another library (professional code or not.....)
     
  19. This may not be the place to ask, but has anyone created an app or spreadsheet that can take the MoTeC data and make suggestions about the setup to resolve possibly large adjustments that are incorrect? Would make creating a setup for each track a little faster to have something instead of having to yet again run through the whole process and hope you don't forget something. Would love to be able to take the saved data and put it into a program and have it tell me that shocks are way off, or springs are way off so that I can quickly create the setup.
     
  20. PLR is located in Race07 > UserData > "your profile name" > "Your Profile Name".PLR