1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC mod tracks not loading

Discussion in 'Assetto Corsa' started by BigGiantRobots, Jul 4, 2016.

  1. Hello all,

    I'm new to the game and have been having a blast. Next to the driving i've been playing around with custom skins and mod cars which has generally been going fine, some cars work, some don't, same with skins...i figure this is because they need updating?

    What i have not once been able to do though, is get a mod track to load.

    -I'm sure they're in the right folders, they (bathurst, donington, la sarthe, laguna, interlagos) show up in the game menus after all. (\Program Files (x86)\Steam\SteamApps\common\assettocorsa\content\tracks)

    - I've checked to see if the assettocorsa.ini warnings as errors setting is set to 0, which it was by default.

    - i've tried it without any post processing

    - i've tried the force 32bit setting

    The only thing i haven't tried is a reinstall, before i do so though...i wanted to see if anyone here knows of anything else i could try? All i've found so far in terms of people with the same issue seems to be at least a year back so i figured a new thread would be better than replying there.

    Any help would be greatly, greatly appreciated...

    PC Specs: Intel Core i5-6600K 3.50GHz | GigaByte B150-HD3P | 16GB DDR4 RAM | NVIDIA GTX 970 4Gb | Samsung SSD 850 Evo 500GB | Panasonic TX-P42GT30E 1920x1080(59.9Hz) | Win10 | Logitech G29 + Shifter

    AC Specs: Fullscreen ON | Vsync ON | FPS Limit 60 | Aniso 8x | AA 4x | World Detail MAX | Shadows High | Smoke generation Ultra | PP Effects ULTRA | Saturation 100% | Motion Blur 12 | Crepuscular rays ON | Heat Shimmering ON | FXAA ON | Mirrors Resolution HIGH | HQ Mirror Reflection ON | Reflection Quality HIGH | Reflection Rendering Frequency HIGH | Video card load ~38%
     
  2. Ensure that per example, circuit_de_la_sarthe is at Program Files (x86)\Steam\steamapps\common\assettocorsa\content\tracks\circuit_de_la_sarthe and not at Program Files (x86)\Steam\steamapps\common\assettocorsa\content\tracks\content\tracks\circuit_de_la_sarthe due to unzipping error. Or if you have them in the correct place but duplicated also under a wrong \content folder under \tracks or \cars, so the game tries to load the car/track from the wrong location first, even if you unzipped them correctly after.
    Other than that, you should be at v1.6.3 as everybody else.
     
  3. Hi AlleyViper,

    thanks a lot for your response, i checked up on the structuring and it seems to be correct, no duplicates (except for a folder on my desktop where i have a copy of all my mods, surely that's not a factor?).

    taking la sarthe as an example, it's in the following folder:
    Program Files (x86)\Steam\steamapps\common\assettocorsa\content\tracks\Circuit de la sarthe_1.1
    And in that folder are the 24hours and nochicane folders. (also the skins and ui folders and the assorted loose files that were in the root of the zipfile)

    I noticed spaces in my foldername and underscores in yours, so i renamed mine the same as yours. it still doesn't load, now it doesn't throw the track not found error anymore, it just pops back to the menu...(and i crossed my fingers and toes and everything ;))

    i'm at v1.6.3 on a 1month old pc, it basically only has steam on it.

    thanks again any and all
     
  4. Did you extract the folder? Because it is compressed so you need a program for it. I use 7zip, free program.
    Open the zipped file with this program and do how I did in the screenshot below. Click on Extract and then click on the ... button to select the destination folder and press Ok. This path is saved in the program, so next time just select it by clicking on the down arrow, next to the three dots button.

    [​IMG]

    ps. not all mods are structured the same, so look inside the folder (for e.g. circuit_de_la_sarthe to see if there's another circuit_de_la_sarthe. In this case there isn't). For other type of mods that start with \assettocorsa\content they can have cars and fonts inside, so in this case in 7zip select the path only until \content, because the rest will be extracted to the remaining folders.
     
    • Agree Agree x 1
  5. You can't change a mod's folder name, as it's needed to work correctly. For that track the correct folder will be assettocorsa\content\tracks\circuit_de_la_sarthe, and then you'll find in there assettocorsa\content\tracks\circuit_de_la_sarthe\nochicane, assettocorsa\content\tracks\circuit_de_la_sarthe\24hours etc. You just need to drag the "circuit_de_la_sarthe" folder inside the zip file to your \tracks folder to have the correct structure. (meanwhile Radu Oros ninja'd me :) )

    Ensure also you don't have placed any similar files in documents\assetto corsa\tracks instead, because it'll cause a failed load.
     
  6. hi guys, thanks again for the replies.

    i'm using peazip to do my extracting which does everything winzip or winrar does, so i doubt that's the problem.

    what i normally do is extract mods to a folder on my desktop in case i ever need to do a fresh install, then i put everything where it needs to be in the way it needs to be from there.
    for arguments sake however, i deleted la sarthe, and extracted it from the zipfile directly to assettocorsa\content\tracks\ which did remove the problem of the incorrectly named folder. now i have exactly the structure AlleyViper describes in the post above, but i still get the same behaviour; loading screen, and then it pops back to the menu, no error.

    i also doublechecked for duplicate folders as instructed.
     
  7. i got it to work!

    the foldername was the issue, which was caused by my bad habit of selecting 'extract to a new folder' on my desktop first. this caused the files to be created in a folder with the same name as the zipfile, which was NOT the correct trackname.

    The reason it still wasn't working when i wrote the above post, was my fault also, the track settings were correct. I was running assetto on my second screen instead of the screen i race on; assetto no liky ergo assetto no worky.

    i'm going to get stuck in retracing my steps with the other tracks (and cars i previously couldn't get to work) but i'm confident these problems will be fixable also.

    THANKS to both of you!
     
    • Like Like x 1
  8. That makes sense, documents\assetto corsa\cfg\video.ini had a display mode # selected for the wrong monitor, so when you ran the launcher in a secondary monitor it'd fail to load any track (as the video mode # won't match). If you intended to run it in the same new monitor as the launcher, you'd have to select the video mode again to write a new video.ini.