1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lost Button 1 & 2 function on G27 Wheel

Discussion in 'F1 2015 - The Game' started by Dick Hobbs, Jul 15, 2015.

  1. Suddenly just lost function on my 1 & 2 buttons when they are used as the LB/RB functions, so i can't navigate through my info menus or my car setup menus and these menu functions are not listed in the setup screen. How do i map these functions back to my 1& 2 buttons?
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Check your buttons are working correctly under Windows, or in the Logitech profiler, if they are OK then :-

    Try starting the game via the keyboard (enter key), do not touch your wheel. Skip through all the start screens using the enter key. This should make the keyboard the default controller, losing any previous customisations.

    Now go to your in-game settings and re-select your G27, hopefully all will be good now.

  3. Thanks Graham but I think I may have found another bug. The long story is this: After braking for lunch, I went back to my PC to continue the game after exiting via my wheel buttons (After double clicking F1 2015 I do not touch my mouse or keyboard) I pressed my #18 button to go through the start up screens but no response. I then started the game as you suggested (using keyboard) and went into my setup screen where it was still showing "CUSTOM" on the top two lines. When using the keyboard to select my G27, that choice was not available, so I exited the game and went to the Logitech profiler and deleted my profile, unplugged my wheel from the usb port and restarted mt PC. I then re plugged in my wheel, made a new profile in the profiler and fired up F1 2015 using the keyboard (only choice I had). When I went into the in game setup, my wheel was back and my previous customization was gone. However the assignments were all over the place and no buttons would give me the LB/RB functions.

    I managed to reassign my buttons for those functions listed for the G27 wheel but the functions that "LB/RB control are not listed in the game settings, so I can't reassign them.

    I have tried re verifying my game in steam but still no dice, so I guess I just start all over and see if it works next time, if not then I am stumped.
  4. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I must admit that I used to unplug my wheel then use the keyboard to set it as the default (in previous games in the series). I wasn't sure if that was necessary anymore.

    My G27 custom settings disappeared today also. I noticed that when I went to bring up the info screen (temperatures etc.) and my camera changed instead :rolleyes:

    Are you sure your wheel is working in Windows OK? Have you actually tested it to ensure all the buttons work? It's dead easy to tug the cable which connects to the gearbox, and dislodge the plug that goes into the connector under the wheel assembly, I've done that before.

    You can miss out the profiler too, and just shut it down. Then use Windows > Control Panel > Devices & Printers > G27 to setup your 360 degree rotation, FFB etc. At least this takes the profiler out of the equation when trying to find a fault. You can test your wheel and buttons there too :)
  5. Thanks again Graham, I will give your suggestions a try hopefully tonight and I will post any feedback I may discover. I have posted this problem with CM Tech assist forum as well.
    • Like Like x 1
  6. Update: Got back into it this evening and after 2 more hours I discovered the problem, for some reason the desktop shortcut must have decided to invalidate. I did nothing, other than to exit the game for lunch and then return after about 30 minutes to resume racing. Only after trying Profiler/no Profiler, delete and create new profile etc, etc with no luck, I thought I'd try starting the game from within Steam and the problem was gone. Why the shortcut suddenly didn't work, I have no idea.
  7. Graham Laing

    Graham Laing
    ...... mostly harmless Staff


    I'm going to leave it there is a confused state. I thought your buttons were not working, not that a shortcut wasn't working :cautious:

    Oh well, at least you are up and running :)
  8. What I am saying is that when I started the game the way I always do, I had the button problems I described in my posts above and no matter what I did, I could not fix it. The problem disappeared when I went into Steam and started the game from there, meaning that the desktop shortcut had some how got corrupted and caused all kinds of controller problems in game. Once I discovered this, I replaced my desktop shortcut.

    The point here is that your game can go wrong and have you running around for a long time (as it did me) looking for the problem in game when the solution is only a few mouse clicks away.
  9. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    It the beauty of PC's, it's what I love about them.

    Constant little niggles, that deepen your understanding of the PC :D

    I say this in the full knowledge that I am about to do a Refresh install of Windows 8.1 within the next hour, to attempt a fix for a corrupted Windows image, the Microsoft provided tools cannot fix it, even though they are meant to. It's screwing up my virtual memory (paging file).

    If all goes well, I'll be back this evening, if it doesn't, see you next month ;)

    PC's :inlove:
  10. Good luck with that, can't tear me away from my W7. :inlove: my W7.