1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logitech G25/G27 Wheel fix!

Discussion in 'MotoGP 14' started by rodney007xx, Jul 13, 2014.

  1. This should work with any controller

    1: Download this:

    2: Install the above into a new folder and open the program, click through and find a profile for your wheel online. Once in familiarize yourself with the application and make sure your controller tab has a "green light" and is responding to your input. Assign the wheel axis to what you would be using on the a controller i.e throttle as R trigger etc. (also assign "start" and "select").
    Make sure your wheel is selected as "game-pad".

    3: Exit and choose save.

    4: Move all the contents of your new folder to the game folder install. Run the application one more time and check your setting is still there. Close once more and then launch the game

    5: When at press enter screen press a key on your wheel, go to the controls window and assign your controls. (it will not remember so must be done every time)

    6: Enjoy smooth and accurate control input.

    You can change the rotation in your device properties (150 deg works well)

    My riding not perfect but you can clearly see the riding style now is much more smooth. (for me anyway) If you haven't tried your wheel for a motorbike game you are seriously missing out!

    Last edited: Jul 13, 2014
  2. Hi Rodney, you tried to help me on steam but its not so easy on their comments screen :)
    I have tried several times now and I cannot get it working - sometimes I have a red light on the tab, other times it is green. I have no idea why it is doing that. But in any case, it makes no difference to my controller.
    I have some really weird stuff going on with the G27 in this game.
    I go to controller menu, & select wheel 1.
    I choose my buttons and exit the menu. If I go back to the menu the buttons have all changed. Sometimes the whole wheel menu is even different, with different choices!
    I gave up and have started using keyboard, really disappointed but I have at least got used to it enough to race reasonably well.

    I just hope Milestone fix this.

    I have also ordered an xbox controller off ebay in the hope that will work instead :(

    On top of that, it is impossible to exit the game! Did they forget to put in an exit option?

    The menus and controls are really letting down an excellent game.

    But thanks for trying to help, I'm glad it works for you, and I'm sure it will work for others, I have used x360ce in the past for GTA & it worked, so I don't know why it is refusing to work this time:)
  3. Keith Windsor - Are you using the Emulator? If so, when you enter the "CONTROLLER" menu it should reflect 'Joypad 1" and not "Wheel1 ".

    Check my Emulator settings under "Advanced".

    Next to the triggers on the Emulator there is a "DOWN ARROW". Click that and then click "RECORD". On the left Trigger you press the Brake and on the right Trigger you press Accelerate.

    Try it or give my settings a go. This is on the understanding that you are using the Emulator.

    According to Milestone the G25/G27 wheels are supported. If so at "PRESS ENTER" in he game do not use the keyboard, but a flipper/button on your wheel that represents "ENTER". Try them all until you get the right one. Only use the "DOWN & UP" keyboard arrows where applicable.

    For the rest you use the buttons/flippers on your keyboard.

    Attached Files:

  4. I appreciate the help zuiplap, & also Rodney007, but I've followed both your instructions & it just is not working. Every time I go into the game, there is no accelerator, I am not able to map one in the menu, it is just blank. I can navigate the menus using keys on the G27 shifter. But the steering, and the keys on the steering wheel, and the accelerator, just do not work.
    Fortunately my xbox controller arrived to day and it works, but I know it is not as precise round the bends as the G27 would be, so I'm disappointed, but at least I can use it.

    MILESTONE, PLEASE don't let us down with the patch. You claim it supports G27, so TEST it properly. I have never had problems with my G27 in any other game, it is NOT working in your game.
  5. The reason you cant map them in the menu is something has gone wrong prior to launching the game, we can work on getting that fixed and then it should work, as I said I am happy to chat with you on Skype to get it working. Name: "lordbossi"
  6. Me also having problems on Windows7 x64
    The emulator does not close down when i have setup up my Logitech GT wheel. and i have to force quite it.
  7. Try another version, same happened for me
  8. Now i finally got it working, since the game is x64 i used the x64 lib files.

    Extract the 360 emulator to the MotoGP14 folder, then extract the whole x64 lib files to motoGP14 folder. Then open the program and try to exit.
    When you have exited you should start MotoGP14x64 and if there comes up messages saying that the emulator has different files and may not work properly, just press OK. then when the game starts, use the wheels assigned START button when you reach the main menu. that worked for me since the game sees my wheel as Joypad1.
  9. I followed your steps and it now works with my Fanatec CSR and CSPv2 pedals. Funny thing is that the controller tab didn't turn green, but it still worked. Shows up as Joystick 1 too. Thanks for your steps.
    • Like Like x 1