1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logitech Driving Force GT no longer recognized

Discussion in 'Sim Racing Hardware' started by Pascal Herbig, Oct 25, 2015.

  1. For a few months now I own a DFGT and everything worked fine as of today. Now when I first connected the wheel and started the Profiler it told me that it didn't recognize anything. I reinstalled the profiler and now I get this. It recognized my Driving Force GT as a completely different wheel. http://i.imgur.com/r5Qdfau.png
    What do I need to do to get my wheel working again?
  2. That is not helpful at all.
  3. Did you try other USB ports? If you use an USB hub, please try a direct connection without a hub.
  4. I tried ports on the front of my PC and on the back of my PC without success.


    Device manager shows it as a Driving Force when it should be a Driving Force GT...
  5. Uninstall Logitech Profiler and reinstall it...?
  6. Stopped counting how many times I have done that. Sometmes after reinstalling it does not recognize the wheel at all.
  7. Tried everything mentioned in that thread. But I cannot seem to find any drivers after I extracted my lgs510_x64 installer
  8. No clue how but I got it working again.
  9. OK, happing racing!
  10. Azfalt Raser

    Azfalt Raser
    DC Premium Member

    After 2 years of use, I am having issues with my DFGT too.

    - Randomly disconnects "Device not recognized" and reconnects
    - Steering gets stuck < 180 degrees of rotation even though everything is set at >540 rotation.
    - Using Logitech profiler, R3E cars are not driveable.
    - Pedals cable keeps falling out - disconnecting my pedals.
    - Power randomly turning on and off (ffb...then no ffb....)
    - [ENTER] button on the wheel is stuck in down position.
    - I LOVE THE SHIFT BUTTONS but they are worn and I get double downshifts or upshifts.

    The issue that causes the most heartache is.....
    the steering getting stuck at <180 degrees of rotation. Literally, I turn my wheel just a an inch (2.5 cm) and it gets me around a hairpin curve. It's almost impossible to get through a chicane without almost or actually spinning if you're not used to the steering.

    When R3E starts, usually the logitech profiler will open with the game. Because it makes R3E cars undriveable, I turn off the logitech profiler. I right click on the task bar, close logitech profiler program. The cars become driveable again.

    Sometimes, R3E will open and Logitech Profiler will open but when I try to close logitech profiler, there is nothing on the taskbar, nothing in Task Manager (no processes, no application) to close.

    But Logitech profiler is still open because my steering is now suddenly < 180 degrees of rotation.
    In this scenario, the only way to fix it is to restart my computer.

    I don't understand why this software does this....
    I have logitech profiler set to 900 degrees of rotation in every field that I could change.
    I have my R3E settings to 540 and/or 900 depending on the car.

    Still....when I start R3E and Logitech profiler, my steering goes to <180 degrees of rotation.

    Time to upgrade to a Thrustmaster?
    I certainly don't want the same issues with the newest logitech wheels.
  11. I'm a DFGT owner too and I have the 180 degrees problem too with R3E. Workaround:
    "Logitech Profiler" => "Edit" => "Specific Game Settings" => Uncheck "Use Special Game Settings" and uncheck "Allow Game To Adjust Settings". And then in "Logitech Profiler" => "Options" => "Global Device Settings" => Uncheck "Allow Game To Adjust Settings".
    Not nice at all, but at least you can drive in R3E.
  12. Azfalt Raser

    Azfalt Raser
    DC Premium Member

    I changed the settings and as shown above.

    Initally, the steering was decent using logitech profiler....but.........

    My wheel was rotated about 15 degrees so I unplugged it and plugged the USB cable back in to reset it.

    Went back into game. Steering switched back to < 180 degrees.:cry:

    So that wasn't the fix I was looking for. Appreciate the help though.
  13. Rotation is set to 900 degrees in the profiler?
  14. Azfalt Raser

    Azfalt Raser
    DC Premium Member

    I've tried re-installing too. Somehow, sometimes, profiler isn't starting properly and the wheel just get's stuck at LESS THAN 90 degrees of rotation. No matter what settings are changed and saved.

    When this happens, there is no way to shut down the profiler using Task Manager since there are no processes or applications showing up.

    If I leave my wheel connected to my pc, and I'm watching a movie or net surfing.....I'll get random "USB device not recognized" & "USB device drivers installed" messages from win7.

    I'm starting to wonder.....
    What if Win7 downloaded generic drivers for the wheel.
    When the wheel disconnects and reconnects, win7 tries to use the windows drivers instead of the logitech profiler.

    That could explain why I can't see any processes or the logitech profiler in the Task Manager.
    Because windows is using it's own drivers for the wheel and not allowing Logitech profiler to open.

    wow - my brain hurts.
  15. Looks like a power-over-USB problem to me. It seems the DFGT isn't getting enough power over USB, so the printed circuit board in the DFGT is switching on and off. Try different USB ports. Try a powered USB hub between the DFGT and your PC.
    FYI: the power connector to the DFGT only powers the FFB motor, not the logic in the DFGT - that's powered by USB only.
  16. Azfalt Raser

    Azfalt Raser
    DC Premium Member

    Ah yes, that was the other issue I was thinking about.

    A few years ago, I discovered my electronics were not charging because windows turned off the power to my USB ports as part of the "Windows Power Savings Option". But I changed the windows power options so the USB ports are always powered.

    I've tried all my USB ports including the ports in the rear. I even replaced my front USB hub for the case.

    I noticed 3 peripherals that connect/disconnect/connect and experience software crashes frequently:
    Logitech headphones
    Logitech Wheel
    Logitech webcam
    I couldn't even get my Logitech flight joystick to work.

    For some reason, after Logitech or some other software upgrade/patch, my pc build/config just doesn't seem to like Logitech anymore.
    Last edited: Nov 6, 2015
  17. Try it on a different PC...?