1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laptop Gaming

Discussion in 'Grand Theft Auto V' started by Ricoow, Apr 15, 2015.

  1. Ricoow

    420 Premium Member

    Hey Guys,
    As my PC is pretty much ded I have to play at my laptop, although for some reason I can't seem to select my NVIDEA GPU for usage with GTA V... It now utilizes my onboard graphics (which apparently are sufficient for low detail)
    Set everything righti n the settings, but game is just not loading up. Any ideas are welcome, will try it all tomorrow night.
    Thanks in advance
  2. James Hemp

    James Hemp
    Green Devils Racing

    go into nvidia control panel and there you should be able to select which game uses which gpu. this should fix it.

    i had the same problem with formula truck but my suggestion from above didn't work. i had to change the gpu id in the game config files.
  3. Ricoow

    420 Premium Member

    The thing is. I did that.
  4. It looks like this is a common issue, especially with laptops. You have to disable the integrated graphics, and that should fix it.
  5. Andrew

    Global Moderator Staff Premium Member

    Found on Rockstar Support:

    GTA 5 PC Intel + AMD/Nvidia GPUs (laptops mostly) FIX!!

    Someone found out how to fix the problem that prevent GTA from launching on Steam once you click on "play" (process starts and closes right away).

    This is the video.

    • You have to disable the GPU performance launch the game, then Rockstar Social Club will start and you can launch the game.
    • Then in the video he closes the game by ending the process in the task manager, which leaves Rockstar Social Club open.
    • Then he enables the GPU performance again.
    • Then he can play GTA 5 with his GPU performance finally.
    Conclusion: GTA 5/Rockstar Social Club doesn't launch with the two GPUs enabled. It's a bug happening only in this game.

    Found in the net:

    If your game does not open on an Intel laptop, follow these instructions:
    o For Nvidia:
    1. Open Device Manager.
    2. Go to Display Adapters.
    3. Disable Nvidia Device.
    4. Start the game launcher.
    5. Reenable Nvidia Card. You need to do this while the launcher is up but not after the full game has loaded.

    o For AMD:
    1. Open Device Manager.
    2. Go to Display Adapters.
    3. Disable Intel Device.
    • Winner Winner x 2
  6. Ricoow

    420 Premium Member

    Thanks @Andrew I knew that though, the launcher crashes if nvidea is enabled :p
    But for some reason (after this launcher) it still selected my Intel card to use with GTA. Result was 1280x720, everything on normal and still laggy performance :p
    Somehow it was fixed and went normal so now I enjoy in full HD. Only problem, once playing on battery instead of on the power net, it literally drains my battery. Lost 20% in 10 minutes of college break rampage :')