• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Keyboard characters mixed up in rFactor

Discussion in 'rFactor' started by Martijn Bont, Oct 10, 2011.

  1. Martijn Bont

    Martijn Bont

    Messages:
    24
    Ratings:
    +0
    Hi guys,

    Since I have this problem for a while now and still haven't found a solution I want to ask if someone here knows about this issue.

    In rFactor I can't make some symbols, like "?" for example. If I try to write that I get "=" instead. All other special symbols are also messed up, but those aren't that important or are available with another key.

    First I thought this was a keyboard language issue in Windows, but I tried to change the languages input in the configuration screen and it didn't help. (it does change it for all other programs, except rFactor.) The same goes for the shortcut 'Ctrl + Shift' (I believe that's the default shortcut), it does change the characters in Windows and other programs.. except in rFactor where nothing changes.

    Hopefully someone knows a solution for this, since it can be quite frustrating sometimes.

    Thanks :)
     
  2. Ivo Simons

    Ivo Simons

    Messages:
    11,357
    Ratings:
    +953
    Go to your controller ini file and search for Keyboard Layout Override and set it to 1.
    That should fix it. :)
     
  3. Martijn Bont

    Martijn Bont

    Messages:
    24
    Ratings:
    +0
    Great, that simple... :)

    Value '2' worked for me btw. Thanks!
     
  4. David Jundt

    David Jundt
    Premium

    Messages:
    1,732
    Ratings:
    +340
    That's it? :O

    I got that too, "!" and "?" aswell as some other were different. Is it wrong from the start after installing or is it possible one made a mistake sometime and actually caused it by pressing some shortcut?
     
  5. David Jundt

    David Jundt
    Premium

    Messages:
    1,732
    Ratings:
    +340
    I tried "1" now, but I still get "é" instead of "!" I think. I got used to hitting another button for the exclamation mark(which is the $, £, etc. by the way), but I still dislike that it doesn't work like my usual laptop keyboard.