1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Just purchased 2 cars and the game/store hasn't recognised my purchases

Discussion in 'RaceRoom Racing Experience' started by monsieurjackb, Sep 25, 2015.

  1. monsieurjackb

    monsieurjackb
    Premium Member

    Right, I'm not entirely sure what to do at this point in time but I thought since sector 3 have a good link with RD, here was a good place to start. Basically, I just purchased in game so through steam; the BMW 320 Turbo (Group 5) + 2 extra liveries and the Audi Quattro 90 (GTO Classic). Came to a total of £4.92, it all went through but when I try to use them in game it asks me to purchase them. So I thought it just hadn't gone through tried again. Ultimately, it turns out I've spent a total of £9.84 and have received nothing for it :(

    I'm pretty disappointed by this, has anyone else had this issue? Any help would be much appreciated because like I said, I'm not really sure what to do

    Cheers
     
  2. Kenny Paton

    Kenny Paton
    Backmarker Champion 2015 & so far this year. Staff Premium Member

    @monsieurjackb I had the problem a couple of hours ago I opened a support ticket but when I went to the store it was sorted, so maybe wait for a hour aand try again. It's the first time I've had any issues.
     
    • Like Like x 1
  3. monsieurjackb

    monsieurjackb
    Premium Member

    Thanks Kenny, that's good to know..well its good to know its not a problem my end. Same here, it's the first time I've had an issue, I'll have a look again now.

    Did you buy anything exciting?
     
  4. monsieurjackb

    monsieurjackb
    Premium Member

    I just tried to submit a ticket but that's not going through either :(

    edit: It has gone through...so now we wait :whistling:
     
  5. Yesterday many ppl had the same issue. Me too but today my buy was in my inventory.
     
  6. I had the same problem....

    I submitted a ticket and the next day I had a reply from tech support informing me they have refreshed my account cache and it should solve the problem....I loaded the game up and all purchases were there.

    I am not sure if refreshing the account cache can be done by players or if its something only tech support can do...

    If you got the game through Steam, maybe its worth verifying game cache....that may have the same effect...I don't know but it's worth a try?
     
    • Like Like x 1
  7. Jempy

    Jempy
    Premium Member

    I have another kind of similar problem.

    Impossible to pay for buying Spa track.
    Pay button works, confirm button also ... but afterwards, this message appears:
    "Please wait ... connecting to game" ( or something like that, my game is in french ).
    I already tried three times during the last days ... twice for 10 minutes, yesterday for more than half an hour ... but nothing happens. I cannot do anything else than killing the process through the task manager.

    I'll try this evening the solution you mention, Tony. Thanks for the idea ... maybe it might do the trick.
     
    • Like Like x 1
  8. monsieurjackb

    monsieurjackb
    Premium Member

    Thanks everyone for the advice, it is all sorted now (they refreshed my account cache too). It was frustrating definitely and should never happen but sector 3 were helpful and it's done nothing to taint my high opinion of r3e :D

    Thanks again :)
     
  9. Jempy

    Jempy
    Premium Member

    Well ... I finally found the reason: ... Steam Overlay was unactivated for some reason I forgot.
    I just checked it when I remembered ... and of course now... everything's working ... better :whistling:

    Feeling a bit idiot ... but this made me think better and deeper. :roflmao:
     
    • Like Like x 1